summaryrefslogtreecommitdiff
path: root/dev-python/nltk
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/nltk')
-rw-r--r--dev-python/nltk/Manifest4
-rw-r--r--dev-python/nltk/nltk-3.7.ebuild4
-rw-r--r--dev-python/nltk/nltk-3.8.1.ebuild47
3 files changed, 52 insertions, 3 deletions
diff --git a/dev-python/nltk/Manifest b/dev-python/nltk/Manifest
index 63e8392..dfbb06b 100644
--- a/dev-python/nltk/Manifest
+++ b/dev-python/nltk/Manifest
@@ -1,3 +1,5 @@
DIST nltk-3.7.gh.tar.gz 2851947 BLAKE2B 4cd4fed9f26de7996bcabbd71d500c072489e79ae0edb29f09577e465227c948efa7130af6975b029e77fb79db015437a9e3311eb28048d02dcc2356441d0908 SHA512 66d79afa59f18f2bf7d086dcb22813c7b92239c05669daa62866dbda06c0ca22367317749cf19db3e41a7bdb405d4f87f72b695aa58fd0669bf36de64f1f9888
-EBUILD nltk-3.7.ebuild 1758 BLAKE2B a6186dfa3df9321a7d26951877591a283287a22a1be3e110fc2751223e919695b550aa6b4cbd1ccb7fa9ed9a46a502be31e162dc76aa638fb787053812a3c979 SHA512 57eb93cb2e58d9c1f668e5f4388896d1d966eca983adce95fb3c7ceaab295c49654fe611e3bafb8278ca03270698dbb3863f5933a3174beea3f57b3841257af1
+DIST nltk-3.8.1.gh.tar.gz 2867926 BLAKE2B 54de1d3ae7cfe0b71ac0f5a62ed3e81e489fa4d322cd32eb4aa4ef60617eb96767a0f3a92c7e5a16e71836cb0d3a1076ae3598b6bcf0af5925c95e1a0ccf70f8 SHA512 5b13eff5d8e628173f5321c293d896919d369bcd586861a7e09bf6fdca2b09f2580902da98ec647bcf9cdc2b33a87c830dda3793de20c31c8bc38c86df8f7930
+EBUILD nltk-3.7.ebuild 1747 BLAKE2B ba7e28721bb9ed45e93552b6def4299f6bd139f197ff849cda59083f3ff51cf7fe035e10d4fc643d74e00a9a76951930475a91bae1e305afce90768bc4e4b4d4 SHA512 790ef13f1b57e887de26b745a8c03479ae8e38117380607936848f4a72eb113b456024fc2e47905fbc767b301cc5a36895520524a62d1ec2af6134dfcfedac26
+EBUILD nltk-3.8.1.ebuild 1348 BLAKE2B 9894b2066e8975e30186f05b4db9f85ff11ae1774addd378864ce5a9cf1a81da58f26d623610528abfd12eb8bee403739ca828fe70953b3b9ea92d38ce5e2d3a SHA512 20312c8b00088defbf7a9e6508f7c9ad7eb7101b21f7ed2263c197bc74328940d9c72b8b8bce8c2cd9e54834433995aafea634b09883ec31861dc49f0b526623
MISC metadata.xml 445 BLAKE2B 4bfcde721368b9c9354799863a7a78d2c04eb789672f52b5449bda3ef567448fa1b434dda9d150aa0ff360477c576ea2fd0bebce40bf80bb843393e245f85278 SHA512 89bb6d0ca2e268e3540cf36e91b57e834eb31f078a91bb7ed7218a17c1a9b63809ae77916822eabf6a3a86286d00ae4a311b33c52e40d9d2e61b6d242f4cef78
diff --git a/dev-python/nltk/nltk-3.7.ebuild b/dev-python/nltk/nltk-3.7.ebuild
index 128b38b..1abb630 100644
--- a/dev-python/nltk/nltk-3.7.ebuild
+++ b/dev-python/nltk/nltk-3.7.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/nltk/nltk/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="amd64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+KEYWORDS="amd64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="tk"
RDEPEND="
@@ -32,7 +32,7 @@ BDEPEND="
dev-python/pyparsing[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
dev-python/twython[${PYTHON_USEDEP}]
- sci-libs/scikit-learn[${PYTHON_USEDEP}]
+ dev-python/scikit-learn[${PYTHON_USEDEP}]
dev-python/scipy[${PYTHON_USEDEP}]
dev-python/matplotlib[${PYTHON_USEDEP}]
)"
diff --git a/dev-python/nltk/nltk-3.8.1.ebuild b/dev-python/nltk/nltk-3.8.1.ebuild
new file mode 100644
index 0000000..4421b60
--- /dev/null
+++ b/dev-python/nltk/nltk-3.8.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite,tk?,xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Natural Language Toolkit"
+HOMEPAGE="https://www.nltk.org/ https://github.com/nltk/nltk/"
+SRC_URI="https://github.com/nltk/nltk/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="tk"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/joblib[${PYTHON_USEDEP}]
+ >=dev-python/nltk-data-20211221
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/twython[${PYTHON_USEDEP}]
+ dev-python/scikit-learn[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ )"
+PDEPEND="dev-python/nltk-data"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ nltk/test/unit/test_downloader.py::test_downloader_using_existing_parent_download_dir
+ nltk/test/unit/test_downloader.py::test_downloader_using_non_existing_parent_download_dir
+)