summaryrefslogtreecommitdiff
path: root/dev-python/langdetect/langdetect-1.0.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/langdetect/langdetect-1.0.9.ebuild')
-rw-r--r--dev-python/langdetect/langdetect-1.0.9.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/langdetect/langdetect-1.0.9.ebuild b/dev-python/langdetect/langdetect-1.0.9.ebuild
new file mode 100644
index 0000000..6439784
--- /dev/null
+++ b/dev-python/langdetect/langdetect-1.0.9.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi
+
+DESCRIPTION="Port of Google's language-detection library to Python"
+HOMEPAGE="
+ https://pypi.org/project/langdetect/
+ https://github.com/Mimino666/langdetect
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest