summaryrefslogtreecommitdiff
path: root/dev-python/hijridate
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hijridate')
-rw-r--r--dev-python/hijridate/Manifest2
-rw-r--r--dev-python/hijridate/hijridate-2.5.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/hijridate/Manifest b/dev-python/hijridate/Manifest
index 0d88a9e..d136758 100644
--- a/dev-python/hijridate/Manifest
+++ b/dev-python/hijridate/Manifest
@@ -1,3 +1,5 @@
DIST hijridate-2.4.1.gh.tar.gz 42771 BLAKE2B 7640d2eb6760f1e496468f0cb11d25c3bb4bf8fc4274b1d802d25b8392a44a83c46564d3f2372f53a37ec10fd914c1fbf096dab359018350662b747f8c1c65a6 SHA512 64fc38afbb59ce5de3611602ed8b0262cf410b66236f57e30aeb3d39db904afbfb17b300dba0ac7ab2163b7c4c000b2d444fa3769f00c7a7e80b8fe4bbc7216c
+DIST hijridate-2.5.0.gh.tar.gz 46488 BLAKE2B f9a20c8cddf2e994e952d24dd16f9113c52564961f6a13d4d40b4cf5933ecacf763ebd735a88fc41fcdcdd4cf4620810ae3504ced71e1284fbcb39b6d6aed321 SHA512 ff096902f30a5664892bdfc6a167ac838e83640a7430db726bc02417e4b34d5790624c260f906ee8143a05efefdee55e37b9dbf390fde514cf2f462743995611
EBUILD hijridate-2.4.1.ebuild 604 BLAKE2B ff0890cb3bd297c858616f046f0895c94dc5430a4998fe80cc613e5e5b32db890d4ff5363bb791ac85acd052450a8764578e29532f6d320ae5b0602caa6a28b6 SHA512 f62eb5c0ad78e58c96c04c943ae2d0a3f5028d5db47f19f1522a85c8053715257892607dced425ba8572309d6c5724abf377f60fef917bb03fabea8ba7a21673
+EBUILD hijridate-2.5.0.ebuild 637 BLAKE2B fd2d9ff84a5501801b7cc3fe5aeb9b6fafe98f3f83f79513b9265ec4e3abf4107ce8972e7610dabd7dedd154a1425147a3e567d8f70852ef5ea4bd906114e5c0 SHA512 7c50ae2a1ea936cb21f6e38ea67192a9b01ea45e67a55503c10779033a298368934047481ff33b830eec5c96066e30a106318277279c5be3df564f2caeb571ba
MISC metadata.xml 456 BLAKE2B cac472a06a7262f98785bfa36fb485f15faf5d92c43c92271a0c2ef0a020c98e6880e98057078446cb9f33824bcad76f54b98e294feea33770896c0791b00703 SHA512 c107f6fd940b7a1d52d08694c06621f1c48c7d94bde209e5624f29ed1b2f82165b7904fa773b6daf63c58ed3b84588e66112c4fd0d550149922e36dd8fd8a50b
diff --git a/dev-python/hijridate/hijridate-2.5.0.ebuild b/dev-python/hijridate/hijridate-2.5.0.ebuild
new file mode 100644
index 0000000..5205926
--- /dev/null
+++ b/dev-python/hijridate/hijridate-2.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Hijri-Gregorian date converter"
+HOMEPAGE="https://github.com/dralshehri/hijridate"
+SRC_URI="https://github.com/dralshehri/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/myst-parser \
+ dev-python/sphinx-notfound-page