summaryrefslogtreecommitdiff
path: root/dev-python/hijridate/hijridate-2.4.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/hijridate/hijridate-2.4.1.ebuild')
-rw-r--r--dev-python/hijridate/hijridate-2.4.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/hijridate/hijridate-2.4.1.ebuild b/dev-python/hijridate/hijridate-2.4.1.ebuild
new file mode 100644
index 0000000..87a9378
--- /dev/null
+++ b/dev-python/hijridate/hijridate-2.4.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Hijri-Gregorian date converter"
+HOMEPAGE="https://github.com/dralshehri/hijridate"
+SRC_URI="https://github.com/dralshehri/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+#S="${WORKDIR}/hijridate-${PV}"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo \
+ dev-python/myst-parser \
+ dev-python/sphinx-notfound-page