summaryrefslogtreecommitdiff
path: root/dev-python/drf-writable-nested/drf-writable-nested-0.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/drf-writable-nested/drf-writable-nested-0.7.0.ebuild')
-rw-r--r--dev-python/drf-writable-nested/drf-writable-nested-0.7.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/drf-writable-nested/drf-writable-nested-0.7.0.ebuild b/dev-python/drf-writable-nested/drf-writable-nested-0.7.0.ebuild
new file mode 100644
index 0000000..cb4ea4b
--- /dev/null
+++ b/dev-python/drf-writable-nested/drf-writable-nested-0.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Writable nested helpers for django-rest-framework's serializers"
+HOMEPAGE="https://github.com/beda-software/drf-writable-nested"
+SRC_URI="https://github.com/beda-software/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest