summaryrefslogtreecommitdiff
path: root/dev-python/djangorestframework
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/djangorestframework')
-rw-r--r--dev-python/djangorestframework/Manifest6
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.14.0.ebuild27
-rw-r--r--dev-python/djangorestframework/metadata.xml4
3 files changed, 25 insertions, 12 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index 5d87272..4cc2bde 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1,3 +1,3 @@
-DIST djangorestframework-3.14.0.tar.gz 1055343 BLAKE2B 90298354a606250688609973b6fc70b3f5c842f263d39eb3989747a43a8d492362a478dd44d920bafdd94caacdce6f2b642519a388153f8835dcc2f13abd21c1 SHA512 063dde9eaaf6adede1b1ce75ec9f61581639e7f0795052019bcf9b9cc02318bd2f5fd825e6893aa2f7353c601e6792f8a52c26351bbb1e930aa841faca61f385
-EBUILD djangorestframework-3.14.0.ebuild 753 BLAKE2B 3d08fba845d52bfeac5b7114254725e0c8f360ceeddd26d85ac5c1a86e819dbc56764eaaeb2acbbff0d284c2aa5a2670d2bf2354c222e8b8139780842ffa06ac SHA512 90d79ac9010f95f0758c1c3a1eafdc3ab255aef7e06561aa6d905322d7f48dc6a16a757fce9f729cb51cae7fa6f68c6a6abab10f4b720189f8473a5a31c96498
-MISC metadata.xml 482 BLAKE2B c23ab3e4522ced64c9d861187752182a82ec47804ecf191b04e138e955bf88e2a88a903033e55f4999d90bd8feaae20e6f6a53143dcb2421c2ba1dcfed3e4a78 SHA512 8e8dcd1092da55f903833493603cb8adb571d358a51de137da09e38067d58c80975ef4942374063958002d6516fc3cd57f8f088a4b9ed9fa8007ac057a3e6f6b
+DIST django-rest-framework-3.14.0.gh.tar.gz 9056443 BLAKE2B 217be67f42207d72d862011a72aecef3e111c1e1dd4b4e090cae6b22dee3fb32e060f7877c498084cf1221eb960b4ca895ef55721f7cabaafe3e36ee152e17a8 SHA512 c1012c656b427e0318b2056e2f984ddc75a5b4e85f375c76fba165ad06e285848eee1bc6dc76c097daec57d780efb2551110199d62ce636a03951aec13ab4013
+EBUILD djangorestframework-3.14.0.ebuild 1307 BLAKE2B 41b40dd945007763cb9c35451b78a2b5eda5263b4cd1a0c95102cc7da2bcca09474f6ebabceb1847f79573936313865c2123b2797cf25a6062b7f48fe75d0e3f SHA512 5ac1a0b7dd41f3cc52d3ad2d356469fecd5f55053930d7ce5df9fb694a3744a14f39404fa36c2bc421bab3498fc01557e9e2d3bf783e54593fd4e1afdf830f14
+MISC metadata.xml 430 BLAKE2B daa4a7fa4c2085627f8a903457f3ebbbbebccba7cf54124bbd0c60b2a05f9bb05a6b303ea6b4b517c406fbfd759803ab3fb95ce45c7c85afa905aadbcb63c905 SHA512 6f15c657338d3cf689da4178b7288d8763fa00b2cc48a5e97e1a669fdcff309ab4ed742183369395ff8292c6627011365b3dcbd44eb77503a98ea47452652fa3
diff --git a/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
index 1571a83..9cd99ed 100644
--- a/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
+++ b/dev-python/djangorestframework/djangorestframework-3.14.0.ebuild
@@ -1,19 +1,29 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{10..12} )
-inherit distutils-r1 pypi
+inherit distutils-r1
+MY_P=django-rest-framework-${PV}
DESCRIPTION="Web APIs with django made easy"
-HOMEPAGE="https://www.django-rest-framework.org/"
+HOMEPAGE="
+ https://www.django-rest-framework.org/
+ https://github.com/encode/django-rest-framework/
+ https://pypi.org/project/djangorestframework/
+"
+SRC_URI="
+ https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~x86"
RDEPEND="
>=dev-python/django-3.0[${PYTHON_USEDEP}]
@@ -21,8 +31,6 @@ RDEPEND="
"
BDEPEND="
test? (
- dev-python/coreapi[${PYTHON_USEDEP}]
- dev-python/coreschema[${PYTHON_USEDEP}]
dev-python/pytest-django[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
)
@@ -32,4 +40,9 @@ distutils_enable_tests pytest
EPYTEST_DESELECT=(
tests/test_description.py::TestViewNamesAndDescriptions::test_markdown
+
+ # require coreapi (but not skipped properly)
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_default_schema_with_custom_title_url_and_desc
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_coreapi_renders_openapi_json_schema
+ tests/schemas/test_managementcommand.py::GenerateSchemaTests::test_renders_corejson_schema
)
diff --git a/dev-python/djangorestframework/metadata.xml b/dev-python/djangorestframework/metadata.xml
index efedfbb..ff8d78a 100644
--- a/dev-python/djangorestframework/metadata.xml
+++ b/dev-python/djangorestframework/metadata.xml
@@ -5,9 +5,9 @@
<email>marcin.deranek@slonko.net</email>
<name>Marcin Deranek</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
- <bugs-to>https://github.com/encode/django-rest-framework/issues</bugs-to>
- <remote-id type="github">encode/django-rest-framework</remote-id>
<remote-id type="pypi">djangorestframework</remote-id>
+ <remote-id type="github">encode/django-rest-framework</remote-id>
</upstream>
</pkgmetadata>