summaryrefslogtreecommitdiff
path: root/dev-python/djangorestframework-guardian
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/djangorestframework-guardian')
-rw-r--r--dev-python/djangorestframework-guardian/Manifest3
-rw-r--r--dev-python/djangorestframework-guardian/djangorestframework-guardian-0.3.0.ebuild41
-rw-r--r--dev-python/djangorestframework-guardian/metadata.xml13
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/djangorestframework-guardian/Manifest b/dev-python/djangorestframework-guardian/Manifest
new file mode 100644
index 0000000..caf4b34
--- /dev/null
+++ b/dev-python/djangorestframework-guardian/Manifest
@@ -0,0 +1,3 @@
+DIST djangorestframework-guardian-0.3.0.gh.tar.gz 9110 BLAKE2B 70e6e347935f3e08b4b3181c591740f4c352bb18dfa2fe20fa8665f124f3228786fcb25b928a66063864729f6da7f5697165b85537813010ffbfa214cc6a4829 SHA512 ce196162f42671e6eeb56b17dd432380ff99626dd541b8d2e7e80e4ec7bfc5c884fd3c37652632363173368f9eb1ae0aa82dc25cb1c46ba927f2170d1abbce94
+EBUILD djangorestframework-guardian-0.3.0.ebuild 998 BLAKE2B 922ab4b016ad81059d0759049e109ec98edfba7385224e779d71dd54560fdcc0fa150a2a3c237a68b5c5f2f07f579f5990f091a7bea83ba7b5771a2068ef91c8 SHA512 6d335bac6f9222e7ba6bdeb9aaa81f0e998dff162d9ef448a78cbd83dbadd9410b2ce6ec20699f62070138d5ef9503d271bbb87a23e106ec3bdab6ebe44d327a
+MISC metadata.xml 511 BLAKE2B e8a807cbda5957e796a6a30461154bf27dbe19332be4c43e9c75379cecd33e841d23382291477bd370fb74fb7129ebcd72f0fe2b8a810c3c66f930a5b7915b1f SHA512 156eb0f58d790163dff2c8ad2f2f0300bfd7b978d31018ee825d526615a080a3e29b824f3065cca010f4e1023db63ad139f014138573e3834257d7c7be6d473c
diff --git a/dev-python/djangorestframework-guardian/djangorestframework-guardian-0.3.0.ebuild b/dev-python/djangorestframework-guardian/djangorestframework-guardian-0.3.0.ebuild
new file mode 100644
index 0000000..ea57d4a
--- /dev/null
+++ b/dev-python/djangorestframework-guardian/djangorestframework-guardian-0.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="django-guardian support for Django REST Framework"
+HOMEPAGE="
+ https://github.com/rpkilby/django-rest-framework-guardian
+ https://pypi.org/project/djangorestframework-guardian/
+"
+SRC_URI="https://github.com/rpkilby/django-rest-framework-guardian/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/django-rest-framework-guardian-${PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/djangorestframework[${PYTHON_USEDEP}]
+ dev-python/django-guardian[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Django 4 compatibility
+ sed -i -e 's/ugettext_lazy/gettext_lazy/g' tests/models.py
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" manage.py test -v 2 tests || die
+}
diff --git a/dev-python/djangorestframework-guardian/metadata.xml b/dev-python/djangorestframework-guardian/metadata.xml
new file mode 100644
index 0000000..ac9ae52
--- /dev/null
+++ b/dev-python/djangorestframework-guardian/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/rpkilby/django-rest-framework-guardian/issues</bugs-to>
+ <remote-id type="github">rpkilby/django-rest-framework-guardian</remote-id>
+ <remote-id type="pypi">djangorestframework-guardian</remote-id>
+ </upstream>
+</pkgmetadata>