summaryrefslogtreecommitdiff
path: root/dev-python/django-compression-middleware/django-compression-middleware-0.5.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-compression-middleware/django-compression-middleware-0.5.0.ebuild')
-rw-r--r--dev-python/django-compression-middleware/django-compression-middleware-0.5.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/django-compression-middleware/django-compression-middleware-0.5.0.ebuild b/dev-python/django-compression-middleware/django-compression-middleware-0.5.0.ebuild
new file mode 100644
index 0000000..32a581c
--- /dev/null
+++ b/dev-python/django-compression-middleware/django-compression-middleware-0.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Django middleware to compress responses using several algorithms."
+HOMEPAGE="https://github.com/friedelwolff/django-compression-middleware"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ dev-python/zstandard[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest