summaryrefslogtreecommitdiff
path: root/dev-python/daphne
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/daphne')
-rw-r--r--dev-python/daphne/Manifest5
-rw-r--r--dev-python/daphne/daphne-3.0.2.ebuild38
-rw-r--r--dev-python/daphne/daphne-4.0.0.ebuild39
-rw-r--r--dev-python/daphne/metadata.xml13
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/daphne/Manifest b/dev-python/daphne/Manifest
new file mode 100644
index 0000000..06174f4
--- /dev/null
+++ b/dev-python/daphne/Manifest
@@ -0,0 +1,5 @@
+DIST daphne-3.0.2.gh.tar.gz 38533 BLAKE2B b2c8dfd6fd575925262d1d6ecda46e34e45150a94e196b92a3d0014beacc6b9ab7798f448d09e04cb735dcc0cb81d7538d186a7d545ac68fd39533ce1604c7c2 SHA512 b96ef908ee9717ffa09952b2dec287cf32f59d828bda4f69b5fbae7cd815212b685e62d3f2cb8542d9b5a18d17070ca2b454bf6cdf6a55450002ff14d4b91abd
+DIST daphne-4.0.0.gh.tar.gz 42313 BLAKE2B 3ab65d0d6bb01910bb83e3cf1a32172cd884b7160ed95cf9915db6b256f6291d57ba0c7c2f9c00ecb0ff8e258eb624ab16b553c6832f1082c8352ee108080d6b SHA512 a07bb10e70ded1d85146224d33049f790cb01693bd515086d9a0fc4072c308ba9f744ff1a7031d4a84eb7a763a13921a44c38a6af752ae68f44162351e8851f2
+EBUILD daphne-3.0.2.ebuild 863 BLAKE2B 115b69c2bea4998d4a67c86dd5f94a05185efd5638c82c12663ebd2d68e1d345a491ab679cb4e773eb57d5954edc7bf63f567601eaabb5e7df8fa24826a04717 SHA512 938d72a21a1d8e15b02077ebd3891cef42ff62ad98e9837331b8624132902df8f20f1ffc96b8d8706bf77e1880bfbc06d90776cad272011cc56e0511a0eb60ad
+EBUILD daphne-4.0.0.ebuild 907 BLAKE2B a17a19d9bd52e4d61686bd43141a2fda60be858525ad30a8dd556a84c74ecfb017492381e79f337fe8a0656284149e98489133c58afbfc3e97b5d0e48b1ffbec SHA512 0d5b3df5c5b14494da284c9b97641222c0f371498192b0ca23c78b40f2e12cddc9020df32c9b304944902053fb0f92ff5b4ec692bc7f73e575d014a827529f68
+MISC metadata.xml 439 BLAKE2B ed90ed24f6799e3b4b320a4b7b6eed42527b25e0af5adf0676c132226b38f6dd5806edbfe80229a9ea7f430bbf2c48b5ca2966da01e7eb323107c48c22d45698 SHA512 be911333f769a9b8826bc956dd061cb6bd347e386bca1981c483eb54d42598eb9ea57ec24306ac323a0824beae7593adc9fd71922cb7437ada0601f64d9d10f0
diff --git a/dev-python/daphne/daphne-3.0.2.ebuild b/dev-python/daphne/daphne-3.0.2.ebuild
new file mode 100644
index 0000000..df23ac6
--- /dev/null
+++ b/dev-python/daphne/daphne-3.0.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP, HTTP2 and WebSocket protocol server for ASGI and ASGI-HTTP"
+HOMEPAGE="https://github.com/django/daphne"
+SRC_URI="https://github.com/django/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-python/asgiref-3.2.10[${PYTHON_USEDEP}]
+ <dev-python/asgiref-4.0[${PYTHON_USEDEP}]
+ >=dev-python/autobahn-0.18[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18.7[ssl,${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+src_test() {
+ ASGI_THREADS=4 distutils-r1_src_test
+}
diff --git a/dev-python/daphne/daphne-4.0.0.ebuild b/dev-python/daphne/daphne-4.0.0.ebuild
new file mode 100644
index 0000000..38c827f
--- /dev/null
+++ b/dev-python/daphne/daphne-4.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP, HTTP2 and WebSocket protocol server for ASGI and ASGI-HTTP"
+HOMEPAGE="https://github.com/django/daphne"
+SRC_URI="https://github.com/django/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=dev-python/asgiref-3.5.2[${PYTHON_USEDEP}]
+ <dev-python/asgiref-4.0[${PYTHON_USEDEP}]
+ >=dev-python/autobahn-22.4.2[${PYTHON_USEDEP}]
+ >=dev-python/django-3.2[${PYTHON_USEDEP}]
+ >=dev-python/twisted-22.4[ssl,${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+src_test() {
+ ASGI_THREADS=4 distutils-r1_src_test
+}
diff --git a/dev-python/daphne/metadata.xml b/dev-python/daphne/metadata.xml
new file mode 100644
index 0000000..a99eb93
--- /dev/null
+++ b/dev-python/daphne/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/django/daphne/issues</bugs-to>
+ <remote-id type="github">django/daphne</remote-id>
+ <remote-id type="pypi">daphne</remote-id>
+ </upstream>
+</pkgmetadata>