summaryrefslogtreecommitdiff
path: root/dev-python/convertdate/convertdate-2.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/convertdate/convertdate-2.4.0.ebuild')
-rw-r--r--dev-python/convertdate/convertdate-2.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/convertdate/convertdate-2.4.0.ebuild b/dev-python/convertdate/convertdate-2.4.0.ebuild
new file mode 100644
index 0000000..a120f58
--- /dev/null
+++ b/dev-python/convertdate/convertdate-2.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Converts between Gregorian dates and other calendar systems."
+HOMEPAGE="https://github.com/fitnr/convertdate https://pypi.org/project/convertdate/"
+SRC_URI="https://github.com/fitnr/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.md )
+
+RDEPEND="
+ >=dev-python/PyMeeus-0.3.13[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/myst-parser \
+ dev-python/sphinx-rtd-theme