summaryrefslogtreecommitdiff
path: root/dev-python/concurrent-log-handler
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/concurrent-log-handler')
-rw-r--r--dev-python/concurrent-log-handler/Manifest4
-rw-r--r--dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild24
-rw-r--r--dev-python/concurrent-log-handler/concurrent-log-handler-0.9.24.ebuild2
3 files changed, 2 insertions, 28 deletions
diff --git a/dev-python/concurrent-log-handler/Manifest b/dev-python/concurrent-log-handler/Manifest
index b6876df..da7f35b 100644
--- a/dev-python/concurrent-log-handler/Manifest
+++ b/dev-python/concurrent-log-handler/Manifest
@@ -1,5 +1,3 @@
-DIST concurrent-log-handler-0.9.20.gh.tar.gz 24916 BLAKE2B 2345a142f4509b94ad9956cd2893ef2a342c5caa2920bdd863a3f2aea183ea957369a3b90d2d240df04f726a3cc74318c5a5dd034813b2b89efeb82ea6cc7684 SHA512 c1cde4a2c02e980d92392fd3d73c315684ac3df84dfa1f135854590d54cfb0776836a8f2b9e99b02f30afc52c01391ebe1c778dccef4c19bc31c0d22c780a27f
DIST concurrent-log-handler-0.9.24.gh.tar.gz 39055 BLAKE2B 37bc4f3a39ecbe999b6518dc088b7bfa5599a32489277e511bac9b66dd1b4c2b188f0452902745a04008e2d539d6a4455638f94fd143a17c6a5e73a260a49cb7 SHA512 22d11dd7a40f72874b588830e615d942f62fe7bb3269094433978b80333ef7755f3171c0624e6d232d5939dfece6ddc330268a5ffe5883e12160c8c1e72acfd6
-EBUILD concurrent-log-handler-0.9.20.ebuild 645 BLAKE2B 2139496d295850bcfc119703019834fd50c52829825816d86956b5b7918b19bf3f8d4717b92670de4d87f0a2e743f4d0c302bd4a103b3a833fb57d509398a81f SHA512 707b2dcb573daed100de4f57917a132f23cde386bade3607e2e2d00c89461421c63fd1bccfb6b5f9b4617d6569e9da010300f2034a3e72273b651e45853c08db
-EBUILD concurrent-log-handler-0.9.24.ebuild 610 BLAKE2B 6b386b072d40aafe72d9d62486e07d52b2fdf646c6cbb491172e4e1f5aac2bd23c04337185ce627d1e6b427bf2f9529d37af9a38234e0dc8b114d8d09b80d897 SHA512 12a145f4ecb55eb5b721cb88ece6c2d37a04e2df1a3268cf317197b9c53b5c72c90221ad1ca8fa4c180085efe76ec8c18001636fde53a6279a786844603ed394
+EBUILD concurrent-log-handler-0.9.24.ebuild 611 BLAKE2B ce79cec638269f4bbdcedc0d2b4276158dbb20f8f0e033d43672a3222d899a7d50d7c5057eec3919664fb5f2e72c20ae00ebfbc7f27e69b1738c09b8413fba47 SHA512 1353e4939e6722499e5ee1e2baebcdd2344391ef1d37e297fc022c9d8fd2cd4314fd3e1c10fde2943e8986d1f408c0360ab83b7b6aefe85a300070b2cf6c65b7
MISC metadata.xml 505 BLAKE2B dad218de3b8ccad3a14150386a121035cfcd6860ef5870e826aa4b94265c89ec5938c3805df79d39c9908e6d48b8e667e28b355a17f77e70dfc25a1f6c25f00b SHA512 662034c51f1da4c2e13698592dadf1f6575f0ffc4f3d111af8d0d08a58fc05d4316b62ea140503d42fd9c1833da9f1b7aacf2d611d4befab0d266c705e192bf9
diff --git a/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild b/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild
deleted file mode 100644
index 708919d..0000000
--- a/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.20.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python logging handler allowing safe concurrent write to the same log file"
-HOMEPAGE="https://github.com/Preston-Landers/concurrent-log-handler"
-SRC_URI="https://github.com/Preston-Landers/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND=">=dev-python/portalocker-1.4.0[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-python_test() {
- ${EPYTHON} stresstest.py || die "Test failed"
-}
diff --git a/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.24.ebuild b/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.24.ebuild
index 28adb42..f9f734d 100644
--- a/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.24.ebuild
+++ b/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.24.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1