summaryrefslogtreecommitdiff
path: root/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.24.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/concurrent-log-handler/concurrent-log-handler-0.9.24.ebuild')
-rw-r--r--dev-python/concurrent-log-handler/concurrent-log-handler-0.9.24.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.24.ebuild b/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.24.ebuild
new file mode 100644
index 0000000..28adb42
--- /dev/null
+++ b/dev-python/concurrent-log-handler/concurrent-log-handler-0.9.24.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python logging handler allowing safe concurrent write to the same log file"
+HOMEPAGE="https://github.com/Preston-Landers/concurrent-log-handler"
+SRC_URI="https://github.com/Preston-Landers/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND=">=dev-python/portalocker-1.6.0[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest