summaryrefslogtreecommitdiff
path: root/dev-python/channels-redis
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/channels-redis')
-rw-r--r--dev-python/channels-redis/Manifest6
-rw-r--r--dev-python/channels-redis/channels-redis-3.4.1.ebuild92
-rw-r--r--dev-python/channels-redis/channels-redis-4.1.0.ebuild (renamed from dev-python/channels-redis/channels-redis-4.0.0.ebuild)21
3 files changed, 11 insertions, 108 deletions
diff --git a/dev-python/channels-redis/Manifest b/dev-python/channels-redis/Manifest
index ecbcabe..91b08a9 100644
--- a/dev-python/channels-redis/Manifest
+++ b/dev-python/channels-redis/Manifest
@@ -1,5 +1,3 @@
-DIST channels-redis-3.4.1.gh.tar.gz 29918 BLAKE2B 4b586f9dc4538986935ae04a719ef62b7d316cc8e43a3f35132bb91d22d781fcef5bb40f8667799b1857f6be44b3a143980d254e7d5e872332ce2f57639a33b5 SHA512 748d3d2061bbe70ed720e2acc8bc80368105bcd81ab58fe5f55342d7147ffc3abae24d21cdc0aca9fefa38fb483ffe6b4278687962bc8bb54825ca9ecd5c7d1f
-DIST channels-redis-4.0.0.gh.tar.gz 27781 BLAKE2B 20fe5d8d742ce2986d6598116bf86a06f89bcdd3840be6e8b3df4af2c53b881fd8560dbdee9d9a9f871c4b3ced3f797472bf42e23219b404d6d7362e85ca0e2d SHA512 1be61a52c750e5d0fa76e2cfb51942de12f92d9ae518bcf7aa83a796f685b75d0b4ca1c056239e77267b39570b877b686b12f78acc6aed7a557e081f98be9eb3
-EBUILD channels-redis-3.4.1.ebuild 2592 BLAKE2B 7698475c285dbabbf2608dd8317fd3d342c0481c62635bb6d29a44cc50264ae47e2f52f0926620975a0d77eabb770ea085847c29ee9f157d3c3885c77de0378c SHA512 9009200711e858921a260d840e6dfae3d1e96fa527b5cae67b83c628ea49f10f0b6e0633d15cca5ae36ea7b075c3663681a8965992f6e2110dc7c6090f13810c
-EBUILD channels-redis-4.0.0.ebuild 1694 BLAKE2B 2399fb58da820be8566132461586829a195ba2a24705d5c41dda1bbeaa16785b08c259776bd0d88a0603d6c10d8595d20d9e0020690d54c9c942e56a21810f5c SHA512 966188739c0d1b4ea84830e46fd8fe4a7174746d8433f1279433999497ba1b9a2a22169efcab2ba7a898912d5600b7cebc9611918e80d52c67c595f68950bdab
+DIST channels-redis-4.1.0.gh.tar.gz 28471 BLAKE2B 04ef90dcd488ed61069ae31a1f184c691c48f48388532fcdd4b7558659cbe299287612bd5ad542436deca8da86b6fed44be65b5fe4a3198ceeaa65a2cad13ad1 SHA512 c1abddc2ada660a44ecadaff6f4fe6c89dd47485839b5ace4b753f8f4697d8a0a6b7ca71cb8289848143cb73a5cacc837a371dda05cef5482c743bde9fb7d135
+EBUILD channels-redis-4.1.0.ebuild 1563 BLAKE2B 7f3d45e6522316c49005720a0724c08a4c0979b8a6868bf972eb9769438b108feb94b4c4326d5ee8af60d80670c96fc726859db5213f6fdd1a1067437e73dcdc SHA512 b7db1be71d3198020f11017e9bd16ba3bcfd5264fa82de4008d4362f0afde4f57d0e4ee1654584bbb00d02df337f85567ff939498ef82f744fc62ac89c6c8e70
MISC metadata.xml 463 BLAKE2B 2a0f6991eacc13262dbce02c797d074939f88c608abc791625d6b73e281836092f6937fd6d21a7b49c06a9d24d710eebe89278e60ebeb3fef7b7c09e10dd91a8 SHA512 30c97610d0ca3c4798c3b4405b6e99a1d0df6250a4ccb53baa95f966250bccec37025e40a49a01e6ab5f4bae39a30e1ed699fffcd95785a46d0435dbf30e1e9f
diff --git a/dev-python/channels-redis/channels-redis-3.4.1.ebuild b/dev-python/channels-redis/channels-redis-3.4.1.ebuild
deleted file mode 100644
index 39db296..0000000
--- a/dev-python/channels-redis/channels-redis-3.4.1.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=${P/-/_}
-DESCRIPTION="Provides Django Channels channel layers that use Redis as a backing store."
-HOMEPAGE="https://github.com/django/channels_redis"
-SRC_URI="https://github.com/django/${PN/-/_}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND="
- >=dev-python/aioredis-1.0[${PYTHON_USEDEP}]
- <dev-python/aioredis-2.0[${PYTHON_USEDEP}]
- >=dev-python/asgiref-3.2.10[${PYTHON_USEDEP}]
- <dev-python/asgiref-4.0[${PYTHON_USEDEP}]
- dev-python/msgpack[${PYTHON_USEDEP}]
- <dev-python/channels-4.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-db/redis
- dev-python/async_generator[${PYTHON_USEDEP}]
- dev-python/async-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-# >=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
-
-DOCS=( README.rst )
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- tests/test_core.py::test_send_receive
- tests/test_core.py::test_send_capacity
- tests/test_core.py::test_process_local_send_receive
- tests/test_core.py::test_reject_bad_channel
- tests/test_core.py::test_reject_bad_client_prefix
- tests/test_core.py::test_group_send_capacity
- tests/test_core.py::test_group_send_capacity_multiple_channels
- tests/test_pubsub.py::test_send_receive
- tests/test_pubsub.py::test_send_receive_sync
- tests/test_pubsub.py::test_multi_send_receive
- tests/test_pubsub.py::test_multi_send_receive_sync
- tests/test_pubsub.py::test_groups_basic
- tests/test_pubsub.py::test_groups_same_prefix
- tests/test_pubsub.py::test_receive_on_non_owned_general_channel
- tests/test_pubsub.py::test_random_reset__channel_name
- tests/test_pubsub.py::test_loop_instance_channel_layer_reference
- tests/test_pubsub.py::test_serialize
- tests/test_pubsub.py::test_deserialize
- tests/test_pubsub.py::test_multi_event_loop_garbage_collection
- tests/test_pubsub.py::test_proxied_methods_coroutine_check
-)
-
-python_prepare_all() {
- # Remove sentinel tests
- rm tests/test{_pubsub,}_sentinel.py
-
- distutils-r1_python_prepare_all
-}
-
-src_test() {
- local redis_pid="${T}"/redis.pid
- local redis_port=6379
-
- einfo "Spawning Redis"
- einfo "NOTE: Port ${redis_port} must be free"
- "${EPREFIX}"/usr/sbin/redis-server - <<-EOF || die
- daemonize yes
- pidfile ${redis_pid}
- port ${redis_port}
- bind 127.0.0.1
- EOF
-
- # Run the tests
- distutils-r1_src_test
-
- # Clean up afterwards
- kill "$(<"${redis_pid}")" || die
-}
diff --git a/dev-python/channels-redis/channels-redis-4.0.0.ebuild b/dev-python/channels-redis/channels-redis-4.1.0.ebuild
index 8b31c7c..3feb269 100644
--- a/dev-python/channels-redis/channels-redis-4.0.0.ebuild
+++ b/dev-python/channels-redis/channels-redis-4.1.0.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
+inherit distutils-r1 optfeature
MY_P=${P/-/_}
DESCRIPTION="Provides Django Channels channel layers that use Redis as a backing store."
@@ -17,20 +17,20 @@ S="${WORKDIR}/${MY_P}"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
RDEPEND="
+ >=dev-python/asgiref-3.2.10[${PYTHON_USEDEP}]
dev-python/channels[${PYTHON_USEDEP}]
- >=dev-python/django-3.2[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.5.3[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-db/redis
dev-python/async-timeout[${PYTHON_USEDEP}]
>=dev-python/cryptography-1.3.0[${PYTHON_USEDEP}]
- dev-python/msgpack[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- >=dev-python/redis-4.2.0[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
)
"
@@ -38,13 +38,6 @@ DOCS=( README.rst )
distutils_enable_tests pytest
-EPYTEST_DESELECT=(
- # Hangs
- tests/test_core.py::test_message_expiry__group_send__one_channel_expires_message
- # Fails with: TypeError: int() argument must be a string, a bytes-like object or a real number, not 'NoneType'
- tests/test_core.py::test_receive_cancel
-)
-
python_prepare_all() {
# Remove sentinel tests
rm tests/test{_pubsub,}_sentinel.py
@@ -71,3 +64,7 @@ src_test() {
# Clean up afterwards
kill "$(<"${redis_pid}")" || die
}
+
+pkg_postinst() {
+ optfeature "Backend encrytion support" dev-python/cryptography
+}