summaryrefslogtreecommitdiff
path: root/dev-python/celery
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/celery')
-rw-r--r--dev-python/celery/Manifest2
-rw-r--r--dev-python/celery/celery-5.4.0.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/dev-python/celery/Manifest b/dev-python/celery/Manifest
index 2ff0df5..1c35706 100644
--- a/dev-python/celery/Manifest
+++ b/dev-python/celery/Manifest
@@ -1,5 +1,7 @@
AUX celery.confd-r2 1442 BLAKE2B df6ab3585c12fef2272979ad3412f08827f59e9306b7b997642ee8bd0d4c84b168f32fd9b6427be3c889af411806d37673853588999d366b549908891491bd6e SHA512 ba3172e56a18df963b5886497c51b8aaf5298b5f3055214217561c8c691678b44c762d4f68f96e597807630af4d9185b7a9d557d13f7ffe25fc0092abcd09354
AUX celery.initd-r2 4293 BLAKE2B 8b19a9e6d41b6691b01f55cb35ba4e8d4d917e2f207e28d692764afb356f1ba1e7e50e89b384739193cc7b9fdead875900e26ea470df81c3bd32139786903f15 SHA512 69d0ab39a4235f5582b89cfe98f4820baafde33f36f4c4ef8850175c626c0c9e1b49f9d59515a153b658f49e22212a85e7a1d8f0f1209f4b794f86546bf00eb8
DIST celery-5.3.6.gh.tar.gz 1563926 BLAKE2B c5f86110f7907b8ae084354dafe4e26adb07702150658ddb60a85f58c3e80106aafb921150c78670d05c68c26f17ad1144b4142d6ec9b86e9c9cdb1b653baaa6 SHA512 529611c0d3bfcbfcc931e5d20cf89a4710a8d2e70639e5c2e991ba020c3c2402bfd38b7ef17ecfbc5fe493f046531094158e81b03610191c3af2b531cc913762
+DIST celery-5.4.0.gh.tar.gz 1589006 BLAKE2B ca63fbd18552f6c345aac8cf8860b868263fcdf7c3836a99d31166fc3feb0087af1a403ff1f4e8f866277fbf7feafa1173691acb4549154d32c55759eae75bad SHA512 e39ea88afb529aba14f621a9809c5e18ff1596754162069410249186b3f1512683fe67bb425994514b39fdea562b55ace89a16d57d614259269adf48427144ef
EBUILD celery-5.3.6.ebuild 3538 BLAKE2B bb252ebf33722b2fbff9cf6872cd9dada8281ccee171993aecac24ca32cd165dc943ed49d977caa528c4cf6d9cbc00b6e08a7dbffa15f208d908571d3b146e3b SHA512 e538d1dd179ec04c750f726ef300b0f298926f4d19b40e97ec2fdbcab302e1e8054acfe1f6893f27d4fbabe45b8cd5cb7553a7980de884fce9a933f6cfe06f25
+EBUILD celery-5.4.0.ebuild 3507 BLAKE2B d7b758077d3935b2c1a01dad3cd005787e1dc23a5049975110715094558a8da6e1d6c213727bde8731e394616c6efaad747f18389db51e85c43706020bdc6770 SHA512 fbe07a02bdac096d0bf47e0277ae74afe3c34d14d8d4f95cc404300c6761b3e8ba03057cb0e6bc12b94184d7b9a9ae25de1a278b54e71b14c68221e9e641da4b
MISC metadata.xml 439 BLAKE2B 96a85f59de6c6e175080209273f5bb7635ed0799a80412b327a5586abd983ef15be94716882bb926bdd683b8d3e5779c33c40d518d057c343df9794d0a7f36c3 SHA512 4b3fc6a37fcb4c09ef21fd8ba7b6a8f9139e143a9517fdc521a768c3a79c85e4dcc485ad2c2ea6874ab10a930fe2206beaa482f24d7f16b590e2a77c246e069f
diff --git a/dev-python/celery/celery-5.4.0.ebuild b/dev-python/celery/celery-5.4.0.ebuild
new file mode 100644
index 0000000..e742a4e
--- /dev/null
+++ b/dev-python/celery/celery-5.4.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+
+inherit bash-completion-r1 distutils-r1 optfeature
+
+MY_PV="${PV/_/}"
+DESCRIPTION="Asynchronous task queue/job queue based on distributed message passing"
+HOMEPAGE="
+ https://celeryproject.org/
+ https://pypi.org/project/celery/
+ https://github.com/celery/celery
+"
+SRC_URI="https://github.com/celery/celery/archive/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND="
+ >=dev-python/billiard-4.2.0[${PYTHON_USEDEP}]
+ <dev-python/billiard-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/click-8.1.2[${PYTHON_USEDEP}]
+ <dev-python/click-9.0.0[${PYTHON_USEDEP}]
+ >=dev-python/click-didyoumean-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/click-plugins-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/click-repl-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
+ >=dev-python/kombu-5.3.4[${PYTHON_USEDEP}]
+ <dev-python/kombu-6.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2022.7[${PYTHON_USEDEP}]
+ >=dev-python/vine-5.1.0[${PYTHON_USEDEP}]
+ <dev-python/vine-6.0.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ $(python_gen_impl_dep 'ncurses(+)')
+ >=dev-python/boto3-1.26.143[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-42.0.5[${PYTHON_USEDEP}]
+ dev-python/elasticsearch[${PYTHON_USEDEP}]
+ >=dev-python/moto-4.1.11[${PYTHON_USEDEP}]
+ <dev-python/moto-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-1.0.8[${PYTHON_USEDEP}]
+ >=dev-python/python-memcached-1.61[${PYTHON_USEDEP}]
+ >=dev-python/pymongo-4.0.2[${PYTHON_USEDEP}]
+ >=dev-python/pytest-celery-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pytest-click[${PYTHON_USEDEP}]
+ >=dev-python/pytest-order-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-subtests-0.12.1[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+ >=dev-python/redis-4.5.2[${PYTHON_USEDEP}]
+ <dev-python/redis-6.0.0[${PYTHON_USEDEP}]
+ dev-python/tblib[${PYTHON_USEDEP}]
+ sci-astronomy/pyephem[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/docutils[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-celery-2.1.1[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-click-5.1.0[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs --no-autodoc
+
+EPYTEST_DESELECT=(
+ # Failing tests
+ t/unit/utils/test_platforms.py::test_fd_by_path
+ t/unit/utils/test_platforms.py::test_DaemonContext::test_open
+)
+
+EPYTEST_IGNORE=(
+ # Disable gcs backend
+ t/unit/backends/test_gcs.py
+)
+
+python_install_all() {
+ # Main celeryd init.d and conf.d
+ newinitd "${FILESDIR}/celery.initd-r2" celery
+ newconfd "${FILESDIR}/celery.confd-r2" celery
+
+ if use examples; then
+ docinto examples
+ dodoc -r examples/.
+ docompress -x "/usr/share/doc/${PF}/examples"
+ fi
+
+ newbashcomp extra/bash-completion/celery.bash "${PN}"
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "msgpack support" dev-python/msgpack
+ optfeature "redis support" dev-python/redis
+ optfeature "auth support" dev-python/pyopenssl
+ optfeature "pyro support" dev-python/Pyro4
+ optfeature "yaml support" dev-python/pyyaml
+ optfeature "memcache support" dev-python/python-memcached
+ optfeature "mongodb support" dev-python/pymongo
+ optfeature "sqlalchemy support" dev-python/sqlalchemy
+ optfeature "sqs support" dev-python/boto
+}