summaryrefslogtreecommitdiff
path: root/dev-python/aioredis
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aioredis')
-rw-r--r--dev-python/aioredis/Manifest5
-rw-r--r--dev-python/aioredis/aioredis-1.3.1.ebuild60
-rw-r--r--dev-python/aioredis/aioredis-2.0.1.ebuild76
-rw-r--r--dev-python/aioredis/metadata.xml13
4 files changed, 154 insertions, 0 deletions
diff --git a/dev-python/aioredis/Manifest b/dev-python/aioredis/Manifest
new file mode 100644
index 0000000..9ce6ff4
--- /dev/null
+++ b/dev-python/aioredis/Manifest
@@ -0,0 +1,5 @@
+DIST aioredis-1.3.1.tar.gz 155577 BLAKE2B eb96758c2cdd4efabe35acc4c0062c2a3d5f7b21dffdb5feacdf2967c0b6b9e7d78a801d839b8482154cc2b4de80df151be8360528e0ae3983d3ffab9f725589 SHA512 12ab821008582435ac4c4c207b7f4c75218eca072cad05d7a91961a1c8801aac18742260fa74b0aa0f1fcd05cc40e30c98ffda94f1b1b5b21a61fd6973bce1e6
+DIST aioredis-2.0.1.tar.gz 111047 BLAKE2B 56f520110bee1a5ef2c19171b6c4c5d6cd4ac440892d36edc4ebf274e7b4ac184fd9e090ad79922f609de4b1dc403a1caa38b271cb1f938357ab9f01ea3f8bfc SHA512 9c2c3fe3e4e4a91e9ca727f8ad78c7c4e6ce1109e4a3043d9ddb929606b6879b1522f3845a3b18d8586ed557a4ab0f6288f27f2b6b0e307343e113f9b9b5fd76
+EBUILD aioredis-1.3.1.ebuild 1558 BLAKE2B 84c6515dae4eabf8862978a3ee4fd0af9a344ac8a7555d9f739ae46a1205f682889b6f9bbabb4534d50d3e29a6b669acfb56d5d3d20ca2bbfa8e73deea0fcff1 SHA512 6e26cb0e1672ae7b8673bf99cac5efaea1e01110d034ce3bc0df32a0020591ef4d0e7b37d52811100f9978b9c17f23bb9e2dda1795317d90d6a1da20fb36544d
+EBUILD aioredis-2.0.1.ebuild 2127 BLAKE2B bbd1f571fd09f9701ac49e4b08f073969c06c122a92b7bbec126ba1c7a5cbf10e4996eb99df267edad9cc3f22f04fb11e659c4a555b7c6a01b78c0494ee2035c SHA512 8232bd4ad046f4b83ed821e0f62e7029e628dc3ef50c463dff1f79fb6076b32ad4a8f69a9e02ee64f2f8eadac4599008aac55dc23c317c64f6ce0d731bfe2b8b
+MISC metadata.xml 455 BLAKE2B 13a9204b5ab5fda06a10c63d05adf834859064ca20d97c7c5168d71662bf2465a1d6311582d3484304958d7c2944c02cd82f4a8977c4a1aebab6e3db4936962d SHA512 a997c25d76ba5241b2b806f7ce262feb944472bd8abbfc2bb50593c736daacfa2e648b37f8be7d1abe8416a57f9dc2ea6a7c438cb4e05af219d9d3740d1e9593
diff --git a/dev-python/aioredis/aioredis-1.3.1.ebuild b/dev-python/aioredis/aioredis-1.3.1.ebuild
new file mode 100644
index 0000000..c1d1bbc
--- /dev/null
+++ b/dev-python/aioredis/aioredis-1.3.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="asyncio (PEP 3156) Redis support"
+HOMEPAGE="https://github.com/aio-libs/aioredis-py"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+ dev-python/hiredis[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-db/redis
+ net-misc/socat
+ )
+"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Failing tests
+ tests/connection_commands_test.py::test_auth
+ tests/connection_test.py::test_connect_tcp_timeout
+ tests/connection_test.py::test_connect_unixsocket_timeout
+ tests/pool_test.py::test_create_connection_timeout
+ tests/pool_test.py::test_pool_idle_close
+ tests/sentinel_commands_test.py::test_master__auth
+ tests/sentinel_failover_test.py::test_auto_failover
+ tests/sentinel_failover_test.py::test_failover_command
+ tests/server_commands_test.py::test_client_list
+ tests/server_commands_test.py::test_client_list__unixsocket
+ tests/server_commands_test.py::test_command_info
+ tests/server_commands_test.py::test_config_set
+ tests/server_commands_test.py::test_debug_object
+ tests/server_commands_test.py::test_debug_sleep
+ tests/stream_commands_test.py::test_xgroup_create
+ tests/stream_commands_test.py::test_xgroup_create_mkstream
+)
+
+python_prepare_all() {
+ sed -e '/^addopts/d' -i setup.cfg
+ # Certificate needed
+ rm tests/ssl_test.py
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/aioredis/aioredis-2.0.1.ebuild b/dev-python/aioredis/aioredis-2.0.1.ebuild
new file mode 100644
index 0000000..94c3930
--- /dev/null
+++ b/dev-python/aioredis/aioredis-2.0.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="asyncio (PEP 3156) Redis support"
+HOMEPAGE="https://github.com/aio-libs/aioredis-py"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-python/async-timeout[${PYTHON_USEDEP}]
+ dev-python/hiredis[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pytest-asyncio
+ )
+"
+
+DOCS=( README.md CHANGELOG.md )
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Failing tests
+ tests/test_commands.py::TestRedisCommands::test_acl_getuser_setuser
+ tests/test_commands.py::TestRedisCommands::test_acl_list
+ tests/test_commands.py::TestRedisCommands::test_config_set
+ tests/test_commands.py::TestRedisCommands::test_readwrite
+ tests/test_commands.py::TestRedisCommands::test_xclaim_trimmed
+ tests/test_commands.py::TestRedisCommands::test_xgroup_create
+ tests/test_commands.py::TestRedisCommands::test_xgroup_create_mkstream
+ tests/test_commands.py::TestRedisCommands::test_xgroup_setid
+ tests/test_connection_pool.py::TestConnection::test_busy_loading_disconnects_socket
+ tests/test_connection_pool.py::TestConnection::test_busy_loading_from_pipeline
+ tests/test_connection_pool.py::TestConnection::test_busy_loading_from_pipeline_immediate_command
+ tests/test_connection_pool.py::TestConnection::test_connect_invalid_password_supplied
+ tests/test_connection_pool.py::TestConnection::test_connect_no_auth_supplied_when_required
+ tests/test_connection_pool.py::TestConnection::test_read_only_error
+)
+
+python_prepare_all() {
+ echo -e '[tool:pytest]\nasyncio_mode = auto' >> setup.cfg
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+
+ einfo "Spawning Redis"
+ einfo "NOTE: Port ${redis_port} must be free"
+ "${EPREFIX}"/usr/sbin/redis-server - <<-EOF || die
+ daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ EOF
+
+ # Run the tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
diff --git a/dev-python/aioredis/metadata.xml b/dev-python/aioredis/metadata.xml
new file mode 100644
index 0000000..5c06c51
--- /dev/null
+++ b/dev-python/aioredis/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/aio-libs/aioredis-py/issues</bugs-to>
+ <remote-id type="github">aio-libs/aioredis-py</remote-id>
+ <remote-id type="pypi">aioredis</remote-id>
+ </upstream>
+</pkgmetadata>