summaryrefslogtreecommitdiff
path: root/dev-python/PyMeeus/PyMeeus-0.5.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyMeeus/PyMeeus-0.5.12.ebuild')
-rw-r--r--dev-python/PyMeeus/PyMeeus-0.5.12.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/PyMeeus/PyMeeus-0.5.12.ebuild b/dev-python/PyMeeus/PyMeeus-0.5.12.ebuild
new file mode 100644
index 0000000..6cc1c78
--- /dev/null
+++ b/dev-python/PyMeeus/PyMeeus-0.5.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python implementation of Jean Meeus astronomical routines"
+HOMEPAGE="
+ https://pypi.org/project/PyMeeus/
+ https://github.com/architest/pymeeus
+"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source \
+ dev-python/sphinx-rtd-theme