summaryrefslogtreecommitdiff
path: root/dev-lang
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/luajit/Manifest3
-rw-r--r--dev-lang/luajit/luajit-2.1.9999.ebuild35
-rw-r--r--dev-lang/luajit/metadata.xml11
-rw-r--r--dev-lang/squeakvm/Manifest2
-rw-r--r--dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild166
5 files changed, 35 insertions, 182 deletions
diff --git a/dev-lang/luajit/Manifest b/dev-lang/luajit/Manifest
index 1571243..5696f73 100644
--- a/dev-lang/luajit/Manifest
+++ b/dev-lang/luajit/Manifest
@@ -1 +1,2 @@
-EBUILD luajit-2.1.9999.ebuild 1176 BLAKE2B d32e9f050c2a00f118d150a586c21736faa62b27d0e5382d1dce3d4f2f87c1c241955119b7ac7f41a47a4a8fd8ba2f726115f0cc84627ac1204c1b2ce8e679a9 SHA512 fdf55a2b12da42953f3b13f8bff7b577852fd527a7e8713ce7048e0eddb2c013a7e10da714f306dd66234c45990f8f50366fbee8bdd3532f3eb5607cb7cdf92d
+EBUILD luajit-2.1.9999.ebuild 1447 BLAKE2B 335112f69e0d19f62b83445a63b4690fb6cb8243cad59c5f3145011fb6648c571042e070632df974b7f39804ac38a01b4d706cc20968223978e187408ede2a5d SHA512 a1693a27c4e8f58402dbbe921ae17011d515c098a9759014ab447cd864b6ba2574d4b1cce0aa0d77c9a7d8056d1b336503a040b4e5e8e95581721421dde33ea8
+MISC metadata.xml 399 BLAKE2B 2fd35ae326810c45ad7ceb12e353b45c668baa3d58f46953bbd95298462e56008f42c4cd7ccb856e911fb506ac19ea363e5bc884f15fd668388ebeb2a7078ea9 SHA512 d8a66320dc503e19214f8138a037d29ffe8069b5e156156373d01334987927ecc7e0b3b2a70026073add20c0af7870a70c92a900686c77a5ccc649696439dcf3
diff --git a/dev-lang/luajit/luajit-2.1.9999.ebuild b/dev-lang/luajit/luajit-2.1.9999.ebuild
index 5993d07..b9dd1cd 100644
--- a/dev-lang/luajit/luajit-2.1.9999.ebuild
+++ b/dev-lang/luajit/luajit-2.1.9999.ebuild
@@ -1,24 +1,25 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit pax-utils toolchain-funcs git-r3
-#MY_PV="$(ver_cut 1-4)"
-#MY_PV="${MY_PV/_beta/-beta}"
-MY_PV="2.1.0-beta3"
+MY_PV="$(ver_cut 1-5)"
+MY_PV="${MY_PV/_beta/-beta}"
+MY_P="LuaJIT-${MY_PV}"
DESCRIPTION="Just-In-Time Compiler for the Lua programming language"
-HOMEPAGE="http://luajit.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://luajit.org/git/luajit-2.0.git"
+HOMEPAGE="https://luajit.org/"
+EGIT_REPO_URI="https://luajit.org/git/luajit.git"
EGIT_BRANCH="v2.1"
+EGIT_CHECKOUT_DIR="${MY_P}"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
# this should probably be pkgmoved to 2.0 for sake of consistency.
SLOT="2"
-KEYWORDS=""
+KEYWORDS="~arm64 -hppa -riscv -sparc"
IUSE="lua52compat static-libs"
_emake() {
@@ -27,26 +28,34 @@ _emake() {
PREFIX="${EPREFIX}/usr" \
MULTILIB="$(get_libdir)" \
DESTDIR="${D}" \
+ CFLAGS="" \
+ LDFLAGS="" \
HOST_CC="$(tc-getBUILD_CC)" \
+ HOST_CFLAGS="${BUILD_CPPFLAGS} ${BUILD_CFLAGS}" \
+ HOST_LDFLAGS="${BUILD_LDFLAGS}" \
STATIC_CC="$(tc-getCC)" \
DYNAMIC_CC="$(tc-getCC) -fPIC" \
TARGET_LD="$(tc-getCC)" \
+ TARGET_CFLAGS="${CPPFLAGS} ${CFLAGS}" \
+ TARGET_LDFLAGS="${LDFLAGS}" \
TARGET_AR="$(tc-getAR) rcus" \
BUILDMODE="$(usex static-libs mixed dynamic)" \
TARGET_STRIP="true" \
- INSTALL_LIB="${ED%/}/usr/$(get_libdir)" \
+ INSTALL_LIB="${ED}/usr/$(get_libdir)" \
+ RELVER=$(ver_cut 3) \
+ PREREL= \
"$@"
}
src_compile() {
+ tc-export_build_env
_emake XCFLAGS="$(usex lua52compat "-DLUAJIT_ENABLE_LUA52COMPAT" "")"
}
-src_install(){
+src_install() {
_emake install
- dosym "${PN}-${MY_PV}" "/usr/bin/${PN}"
- pax-mark m "${ED}usr/bin/luajit-${MY_PV}"
+ pax-mark m "${ED}/usr/bin/luajit-${MY_PV}"
HTML_DOCS="doc/." einstalldocs
}
diff --git a/dev-lang/luajit/metadata.xml b/dev-lang/luajit/metadata.xml
new file mode 100644
index 0000000..78900a0
--- /dev/null
+++ b/dev-lang/luajit/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <use>
+ <flag name="lua52compat">Enable some upwards-compatible features from Lua 5.2 that are unlikely to break existing code</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-lang/squeakvm/Manifest b/dev-lang/squeakvm/Manifest
deleted file mode 100644
index bac05e0..0000000
--- a/dev-lang/squeakvm/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST Squeak-4.10.2.2614-src.tar.gz 3297314 BLAKE2B 03c89ea96ed005f1d7a25e6b1016f39bec2dbd7e2282a12c1b02ab57859477d87e3098426c55411fc06e250207830b7e50a23e6330ca64fd967613f2af86e180 SHA512 b823fb97f7826dbbae5feeb15ffc3ab7e11cf27c5a3cc3f2cf2f8c39b56af5f9d0078d020a4b8f72b997198d296be6d85ec10e0bca10d5214bf586e1e0587f07
-EBUILD squeakvm-4.10.2.2614.ebuild 3873 BLAKE2B 2be33c6ca4b011557ad37855b1bcd1e4985e6da7c871a6c7be44bdac282af37c387914bbb1ca4243d411e3dda5291f8c7b982e50154def30c81a4d1e4d3b1109 SHA512 7d5ed1b91f1bd639026336c13bd0681f9e78c6419bf3dbe7ae4f8eb97dcc4a502c3a6831d9bd159e6b97dc707d0a20b1bb1a137dcf353dcf3387774ee35c362b
diff --git a/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild b/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild
deleted file mode 100644
index baa6678..0000000
--- a/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit fixheadtails
-DESCRIPTION="Highly-portable Smalltalk-80 implementation"
-HOMEPAGE="http://www.squeak.org/"
-SRC_URI="http://squeakvm.org/unix/release/Squeak-${PV}-src.tar.gz"
-LICENSE="Apple"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+X +mmx +threads +iconv +opengl image64 alsa oss pulseaudio nas +v4l fbcon dbus +scratch examples"
-
-DEPEND="X? ( x11-libs/libX11 x11-libs/libXext x11-libs/libXt )
- dev-util/cmake
- media-libs/freetype
- >=x11-libs/cairo-1.8.6
- >=x11-libs/pango-1.20.5
- >=dev-libs/glib-2.20.1:2
- virtual/libffi
- sys-apps/util-linux
- iconv? ( virtual/libiconv )
- opengl? ( virtual/opengl )
- v4l? ( >=media-libs/libv4l-0.5.8 )
- alsa? ( media-libs/alsa-lib )
- oss? ( media-libs/alsa-oss )
- pulseaudio? ( media-sound/pulseaudio )
- nas? ( media-libs/nas )
- dbus? ( sys-apps/dbus )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/Squeak-${PV}-src"
-
-src_prepare() {
- ht_fix_all
- eapply_user
- if ! use examples; then
- rm -rf unix/vm-display-custom
- rm -rf unix/vm-sound-custom
- fi
-}
-
-src_configure() {
- local myconf=""
- if use X; then
- myconf="${myconf} --with-x"
- else
- myconf="${myconf} --without-x"
- fi
- if use threads; then
- myconf="${myconf} --enable-mpg-pthread"
- else
- myconf="${myconf} --disable-mpg-pthread"
- fi
- if use iconv; then
- myconf="${myconf} --enable-iconv"
- else
- myconf="${myconf} --disable-iconv"
- fi
-
- if use opengl; then
- myconf="${myconf} --with-gl"
- else
- myconf="${myconf} --without-gl"
- fi
-
- if use alsa; then
- myconf="${myconf} --with-alsa"
- else
- myconf="${myconf} --without-alsa"
- fi
-
- if use oss; then
- myconf="${myconf} --with-oss"
- else
- myconf="${myconf} --without-oss"
- fi
-
- if use pulseaudio; then
- myconf="${myconf} --with-pulse"
- else
- myconf="${myconf} --without-pulse"
- fi
-
- if use nas; then
- myconf="${myconf} --with-NAS"
- else
- myconf="${myconf} --without-NAS"
- fi
-
- if use v4l; then
- myconf="${myconf} --with-CameraPlugin"
- else
- myconf="${myconf} --without-CameraPlugin"
- fi
-
- if use fbcon; then
- myconf="${myconf} --with-fbdev"
- else
- myconf="${myconf} --without-fbdev"
- fi
-
- if use dbus; then
- myconf="${myconf} --with-DBusPlugin"
- else
- myconf="${myconf} --without-DBusPlugin"
- fi
-
- if use scratch; then
- myconf="${myconf} --with-ScratchPlugin"
- else
- myconf="${myconf} --without-ScratchPlugin"
- fi
-
- if use X; then
- myconf="${myconf} --with-x"
- else
- myconf="${myconf} --without-x"
- fi
-
- if use X; then
- myconf="${myconf} --with-x"
- else
- myconf="${myconf} --without-x"
- fi
-
- #use mmx && myconf="${myconf} --enable-mpg-mmx"
- #use threads && myconf="${myconf} --enable-mpg-pthread"
- #use iconv || myconf="${myconf} --disable-iconv"
- #use opengl || myconf="${myconf} --without-gl"
- use image64 && myconf="${myconf} --image64"
- #use alsa || myconf="${myconf} --without-alsa"
- #use oss || myconf="${myconf} --without-OSS"
- #use pulseaudio || myconf="${myconf} --without-pulse"
- #use nas || myconf="${myconf} --without-NAS"
- #use v4l || myconf="${myconf} --without-CameraPlugin"
- #use fbcon || myconf="${myconf} --without-fbdev"
- #use dbus || myconf="${myconf} --without-DBusPlugin"
- #use scratch || myconf="${myconf} --without-ScratchPlugin"
-
- cd "${S}"
- touch unix/npsqueak/CMakeLists.txt
- mkdir build
- cd build
- ../unix/cmake/configure \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- --with-ffi=x86-sysv \
- --without-npsqueak \
- --without-quartz \
- --without-Sun \
- --without-MaxOSX \
- --without-WeDoPlugin \
- --with-FT2Plugin \
- --with-SqueakFFIPrims \
- ${myconf} || die "configure failed"
-}
-
-src_install() {
- dodoc README unix/ChangeLog
- cd "${S}"/build
- emake DESTDIR="${D}" ROOT="${D}" docdir=/usr/share/doc/"${PF}" install || die
- exeinto /usr/lib/squeak
- exeinto /usr/lib/ckformat
-}