summaryrefslogtreecommitdiff
path: root/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild')
-rw-r--r--dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild49
1 files changed, 22 insertions, 27 deletions
diff --git a/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild b/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild
index 8071784..baa6678 100644
--- a/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild
+++ b/dev-lang/squeakvm/squeakvm-4.10.2.2614.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit versionator fixheadtails
+
+EAPI=7
+inherit fixheadtails
DESCRIPTION="Highly-portable Smalltalk-80 implementation"
HOMEPAGE="http://www.squeak.org/"
SRC_URI="http://squeakvm.org/unix/release/Squeak-${PV}-src.tar.gz"
@@ -10,7 +11,6 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="+X +mmx +threads +iconv +opengl image64 alsa oss pulseaudio nas +v4l fbcon dbus +scratch examples"
-
DEPEND="X? ( x11-libs/libX11 x11-libs/libXext x11-libs/libXt )
dev-util/cmake
media-libs/freetype
@@ -23,7 +23,7 @@ DEPEND="X? ( x11-libs/libX11 x11-libs/libXext x11-libs/libXt )
opengl? ( virtual/opengl )
v4l? ( >=media-libs/libv4l-0.5.8 )
alsa? ( media-libs/alsa-lib )
- oss? ( || ( media-libs/alsa-oss media-sound/oss ) )
+ oss? ( media-libs/alsa-oss )
pulseaudio? ( media-sound/pulseaudio )
nas? ( media-libs/nas )
dbus? ( sys-apps/dbus )"
@@ -42,93 +42,88 @@ src_prepare() {
src_configure() {
local myconf=""
- if use X; then
+ if use X; then
myconf="${myconf} --with-x"
else
myconf="${myconf} --without-x"
fi
- if use threads; then
+ if use threads; then
myconf="${myconf} --enable-mpg-pthread"
else
myconf="${myconf} --disable-mpg-pthread"
fi
- if use iconv; then
+ if use iconv; then
myconf="${myconf} --enable-iconv"
else
myconf="${myconf} --disable-iconv"
fi
- if use opengl; then
+ if use opengl; then
myconf="${myconf} --with-gl"
else
myconf="${myconf} --without-gl"
fi
- if use alsa; then
+ if use alsa; then
myconf="${myconf} --with-alsa"
else
myconf="${myconf} --without-alsa"
fi
- if use oss; then
+ if use oss; then
myconf="${myconf} --with-oss"
else
myconf="${myconf} --without-oss"
fi
- if use pulseaudio; then
+ if use pulseaudio; then
myconf="${myconf} --with-pulse"
else
myconf="${myconf} --without-pulse"
fi
- if use nas; then
+ if use nas; then
myconf="${myconf} --with-NAS"
else
myconf="${myconf} --without-NAS"
fi
- if use v4l; then
+ if use v4l; then
myconf="${myconf} --with-CameraPlugin"
else
myconf="${myconf} --without-CameraPlugin"
fi
- if use fbcon; then
+ if use fbcon; then
myconf="${myconf} --with-fbdev"
else
myconf="${myconf} --without-fbdev"
fi
- if use dbus; then
+ if use dbus; then
myconf="${myconf} --with-DBusPlugin"
else
myconf="${myconf} --without-DBusPlugin"
fi
- if use scratch; then
+ if use scratch; then
myconf="${myconf} --with-ScratchPlugin"
else
myconf="${myconf} --without-ScratchPlugin"
fi
-
- if use X; then
+ if use X; then
myconf="${myconf} --with-x"
else
myconf="${myconf} --without-x"
fi
-
- if use X; then
+ if use X; then
myconf="${myconf} --with-x"
else
myconf="${myconf} --without-x"
fi
-
-
-
#use mmx && myconf="${myconf} --enable-mpg-mmx"
#use threads && myconf="${myconf} --enable-mpg-pthread"
#use iconv || myconf="${myconf} --disable-iconv"
@@ -143,7 +138,7 @@ src_configure() {
#use dbus || myconf="${myconf} --without-DBusPlugin"
#use scratch || myconf="${myconf} --without-ScratchPlugin"
- cd ${S}
+ cd "${S}"
touch unix/npsqueak/CMakeLists.txt
mkdir build
cd build
@@ -164,8 +159,8 @@ src_configure() {
src_install() {
dodoc README unix/ChangeLog
- cd ${S}/build
- emake DESTDIR=${D} ROOT=${D} docdir=/usr/share/doc/${PF} install || die
+ cd "${S}"/build
+ emake DESTDIR="${D}" ROOT="${D}" docdir=/usr/share/doc/"${PF}" install || die
exeinto /usr/lib/squeak
exeinto /usr/lib/ckformat
}