summaryrefslogtreecommitdiff
path: root/app-portage/epm/epm-1.40.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/epm/epm-1.40.ebuild')
-rw-r--r--app-portage/epm/epm-1.40.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-portage/epm/epm-1.40.ebuild b/app-portage/epm/epm-1.40.ebuild
new file mode 100644
index 0000000..853bf26
--- /dev/null
+++ b/app-portage/epm/epm-1.40.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils prefix
+
+DESCRIPTION="rpm workalike for Gentoo Linux"
+HOMEPAGE="https://github.com/fuzzyray/epm"
+SRC_URI="http://dev.gentoo.org/~fuzzyray/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-prefix.patch
+ eprefixify epm
+}
+
+src_compile() {
+ pod2man epm > epm.1 || die "pod2man failed"
+}
+
+src_install() {
+ dobin epm || die
+ doman epm.1
+}