summaryrefslogtreecommitdiff
path: root/app-portage/epm/epm-1.40.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage/epm/epm-1.40.ebuild')
-rw-r--r--app-portage/epm/epm-1.40.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/app-portage/epm/epm-1.40.ebuild b/app-portage/epm/epm-1.40.ebuild
index 2dff1ce..3eb633b 100644
--- a/app-portage/epm/epm-1.40.ebuild
+++ b/app-portage/epm/epm-1.40.ebuild
@@ -3,11 +3,13 @@
EAPI=8
-inherit prefix
+inherit git-r3 prefix
DESCRIPTION="rpm workalike for Gentoo Linux"
HOMEPAGE="https://github.com/fuzzyray/epm"
-S="${WORKDIR}/"
+
+EGIT_REPO_URI="https://github.com/ganto/epm.git"
+EGIT_COMMIT="df329631d9be14305a5cc5484a03c06012a9cc0f"
LICENSE="GPL-2"
SLOT="0"
@@ -18,11 +20,10 @@ DEPEND="dev-lang/perl"
RDEPEND="${DEPEND}"
src_unpack() {
- :
+ git-r3_src_unpack
}
src_prepare() {
- cp "${FILESDIR}"/epm "${S}"/epm
eprefixify epm
eapply_user
}