summaryrefslogtreecommitdiff
path: root/app-misc/workrave/workrave-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/workrave/workrave-9999.ebuild')
-rw-r--r--app-misc/workrave/workrave-9999.ebuild52
1 files changed, 39 insertions, 13 deletions
diff --git a/app-misc/workrave/workrave-9999.ebuild b/app-misc/workrave/workrave-9999.ebuild
index 3b8ef41..0762dae 100644
--- a/app-misc/workrave/workrave-9999.ebuild
+++ b/app-misc/workrave/workrave-9999.ebuild
@@ -4,34 +4,52 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..11} )
-inherit cmake python-single-r1 vcs-snapshot
+inherit cmake python-single-r1 xdg-utils
DESCRIPTION="Helpful utility to attack Repetitive Strain Injury (RSI)"
HOMEPAGE="https://workrave.org/"
MY_PV=$(ver_rs 1- '_')
if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/rcaelers/${PN}"
- S="${WORKDIR}/${P}"
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rcaelers/${PN}"
+ S="${WORKDIR}/${P}"
else
- SRC_URI="https://github.com/rcaelers/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ SRC_URI="https://github.com/rcaelers/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
fi
LICENSE="GPL-3+"
SLOT="0"
-IUSE="gui nls"
+IUSE="dbus debug gstreamer +gtk indicator mate nls pulseaudio test xfce"
+RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-DEPEND="${RDEPEND}
+RDEPEND="
>=x11-themes/adwaita-icon-theme-43
>=dev-libs/spdlog-1.10.0
- >=dev-cpp/gtkmm-3.24.5
- >=x11-libs/gtk+-3.24.34
>=dev-util/pkgconf-1.8.0
- >=dev-libs/boost-1.79.0
+ >=dev-libs/boost-1.73.0
+ dbus? (
+ ${PYTHON_DEPS}
+ dev-python/jinja
+ )
+ gstreamer? ( media-libs/gstreamer:1.0 )
+ gtk? (
+ >=dev-libs/glib-2.56.0
+ >=x11-libs/gtk+-3.22.0
+ >=dev-cpp/gtkmm-3.22.5
+ )
+ indicator? (
+ >=dev-libs/libayatana-indicator-0.4:3
+ )
+ mate? ( >=mate-base/mate-panel-1.20.0 )
nls? ( >=sys-devel/gettext-0.21 )
+ pulseaudio? (
+ dev-libs/glib:2
+ media-libs/libpulse
+ )
+ xfce? ( >=xfce-base/xfce4-panel-4.12 )
"
pkg_setup() {
@@ -44,6 +62,14 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
+ -DWITH_DBUS=$(usex dbus)
+ -DWITH_GSTREAMER=$(usex gstreamer)
+ -DWITH_INDICATOR=$(usex indicator)
+ -DWITH_MATE=$(usex mate)
+ -DWITH_PULSE=$(usex pulseaudio)
+ -DWITH_TESTS=$(usex test)
+ -DWITH_XFCE4=$(usex xfce)
+ -DWITH_TRACING=$(usex debug)
)
cmake_src_configure
}
@@ -57,9 +83,9 @@ src_install() {
}
pkg_postinst() {
- use gui && xdg_icon_cache_update
+ xdg_icon_cache_update
}
pkg_postrm() {
- use gui && xdg_icon_cache_update
+ xdg_icon_cache_update
}