summaryrefslogtreecommitdiff
path: root/app-misc/workrave/workrave-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/workrave/workrave-9999.ebuild')
-rw-r--r--app-misc/workrave/workrave-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-misc/workrave/workrave-9999.ebuild b/app-misc/workrave/workrave-9999.ebuild
index 0762dae..098ac94 100644
--- a/app-misc/workrave/workrave-9999.ebuild
+++ b/app-misc/workrave/workrave-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake python-single-r1 xdg-utils
@@ -21,7 +21,7 @@ fi
LICENSE="GPL-3+"
SLOT="0"
-IUSE="dbus debug gstreamer +gtk indicator mate nls pulseaudio test xfce"
+IUSE="dbus debug gstreamer +gtk indicator mate nls pulseaudio test wayland xfce"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -38,7 +38,7 @@ RDEPEND="
gtk? (
>=dev-libs/glib-2.56.0
>=x11-libs/gtk+-3.22.0
- >=dev-cpp/gtkmm-3.22.5
+ >=dev-cpp/gtkmm-3.22.0
)
indicator? (
>=dev-libs/libayatana-indicator-0.4:3
@@ -68,8 +68,10 @@ src_configure() {
-DWITH_MATE=$(usex mate)
-DWITH_PULSE=$(usex pulseaudio)
-DWITH_TESTS=$(usex test)
- -DWITH_XFCE4=$(usex xfce)
-DWITH_TRACING=$(usex debug)
+ -DWITH_UI=$(usex gtk Gtk+3 None)
+ -DWITH_WAYLAND=$(usex wayland)
+ -DWITH_XFCE4=$(usex xfce)
)
cmake_src_configure
}