summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/scikit-learn/Manifest2
-rw-r--r--sci-libs/scikit-learn/scikit-learn-1.3.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/sci-libs/scikit-learn/Manifest b/sci-libs/scikit-learn/Manifest
index 2aab626..5e1954a 100644
--- a/sci-libs/scikit-learn/Manifest
+++ b/sci-libs/scikit-learn/Manifest
@@ -1,3 +1,5 @@
DIST scikit-learn-1.2.2.gh.tar.gz 7398844 BLAKE2B ae751f3adc575c9464af83b2ab3f04fa1441da56384a1316279f596ec5fd747b8fd25a27b45af346a5ee3518d851911280632b5ead13cfb17ec4f68dd26884d6 SHA512 5c1fcb5bde5f7e41d40fa111a65253a7ffc989b7a425284b99e526a65c703ee234a45fc1fb20dcd63d0c09abbe2debfc9d2ef9f880153541cbe9f8f5e925f18f
+DIST scikit-learn-1.3.0.gh.tar.gz 7622999 BLAKE2B 8ca0dcfaaa429ac4daf1a9f601157d9de7719d6d6fa683af6a7c2864eb12f2c745d1bb52467ce93c9a99574c10e7af0af62c5d44fac7cad879d514d81eefcfb9 SHA512 bc6f9647dc2e984a13c2a8a00d37ef21a5cacd45809a8f41fb26529c6d1774b1a1471138f7e4d77f032682aaef3c04b184bbd19894fb80647a6593f32de8cec7
EBUILD scikit-learn-1.2.2.ebuild 1544 BLAKE2B dc079564a6af225e7856937dafabf9215305f267841af12876e1dce93f0892de1874b749472a1a94a827d1aa45ef0f6634e5ca2951f9ab3b97776995ab3ce9f6 SHA512 2badc71299d2cf023ecb27eae9d0414a21b5cebf69cd74b2a82dfcbe367301c60ef14f948ec6452ea6ca2ffc2133dad592aaa945ccd30cd2a1c809cb05af6488
+EBUILD scikit-learn-1.3.0.ebuild 1580 BLAKE2B 8db0f0329fc0e1438ffb50e7efa378b96734d20ca1fbe1e5fa7c521a5f54596bd47e8a4442c13608f1846885d45859cd49b8b6f73e55f273a39fd4a9e177275c SHA512 fd3f613e046c003545fce1712aa350be0289c862f46bb1b4707d95f54cb3324250aa214ee7755f2ef453a1a6a8ab6bd743311914de13e8b59e274e27fd4231bd
MISC metadata.xml 616 BLAKE2B bdf5878946d2a45ebd86d25bcc1dab9675b1799f8406fa04422fae46ac01608fc232c172ba78e31d7a1dd0e7645f3e7b36577289995b2dc948b9749fabc7ca57 SHA512 f98e83018ba42d1cb71749a54f48d14e4692a2f882c1cbf0faa72d0bfde200d331f3fe6928a12edfe3b02034b130ad6300e959e974413fba6af79effd0441c00
diff --git a/sci-libs/scikit-learn/scikit-learn-1.3.0.ebuild b/sci-libs/scikit-learn/scikit-learn-1.3.0.ebuild
new file mode 100644
index 0000000..32b33a1
--- /dev/null
+++ b/sci-libs/scikit-learn/scikit-learn-1.3.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Machine learning library for Python"
+HOMEPAGE="https://scikit-learn.org/stable/"
+SRC_URI="https://github.com/scikit-learn/scikit-learn/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
+IUSE="examples"
+
+DEPEND="
+ virtual/blas:=
+ virtual/cblas:=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/wheel[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/joblib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/threadpoolctl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# For some reason this wants to use urllib to fetch things from the internet
+#distutils_enable_sphinx doc \
+# dev-python/matplotlib \
+# dev-python/memory_profiler \
+# dev-python/numpydoc \
+# dev-python/pandas \
+# dev-python/pillow \
+# dev-python/seaborn \
+# dev-python/sphinx-gallery \
+# dev-python/sphinx-prompt \
+# sci-libs/scikit-image
+
+python_test() {
+ # This needs to be run in the install dir
+ cd "${WORKDIR}/${P}-${EPYTHON//./_}/install/usr/lib/${EPYTHON}/site-packages/sklearn" || die
+ distutils-r1_python_test
+}
+
+python_install_all() {
+ find "${S}" -name \*LICENSE.txt -delete || die
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}