summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--xfce-base/xfdesktop/Manifest3
-rw-r--r--xfce-base/xfdesktop/files/non-wayland.patch37
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.19.0.ebuild67
3 files changed, 107 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
new file mode 100644
index 0000000..cf9b70f
--- /dev/null
+++ b/xfce-base/xfdesktop/Manifest
@@ -0,0 +1,3 @@
+AUX non-wayland.patch 1151 BLAKE2B 5b1ef713034e11c79eaf78b78ebac124ae67b53f5ca66340c978678578e51ee3f4a263e263ebad9cdcff7baddba8be1427da41eca7be37284741273402eae903 SHA512 d284148b998d47b347d747ee88d913d7fe199faf4b58af4a2be3660f7989a31884b767c6690bafbbf4170ab67941f64beaf603ecafdb69b7af2c97c6e18b43dd
+DIST xfdesktop-4.19.0.tar.bz2 2145725 BLAKE2B 18ed97b8bb9ee769de29490383fd089eb884081c95e662350c9e0c05aa9812a4f44e8911c5bb74e026aa1fea22840245a68e1514dd6e439af8dd553c82da562c SHA512 dd8d479b7a43733dc49f692bd88ad5a290d5fa4cdbddf42be293921c750d3017e9c6671cc56ba8888a0df8d3951b0993dffa88418032ad7c68f85d8756081e40
+EBUILD xfdesktop-4.19.0.ebuild 1444 BLAKE2B 078a955c8b853949ec605d7be28984416ec46fa82325049c1a8979b37cf87694a96c289980a2c5ec925518a3edea8b21e1cdf3be5bca83209c19eef555e6d42e SHA512 66dec006528c32c2622a5fa44b5db5beefb6f0d7405df48e5f614c0f3769c48f4454625adcb84b7a10549ce1fd087fe6504c5f06336faf3e30a64cb8a14b5e7b
diff --git a/xfce-base/xfdesktop/files/non-wayland.patch b/xfce-base/xfdesktop/files/non-wayland.patch
new file mode 100644
index 0000000..016c129
--- /dev/null
+++ b/xfce-base/xfdesktop/files/non-wayland.patch
@@ -0,0 +1,37 @@
+From 84e087b6f36a06d4db503d6aec4bef415b4b5df2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C4=90o=C3=A0n=20Tr=E1=BA=A7n=20C=C3=B4ng=20Danh?=
+ <congdanhqx@gmail.com>
+Date: Fri, 17 Feb 2023 19:48:52 +0700
+Subject: [PATCH] main: Fix control (always) reach end of non void function
+
+When configured with --disable-wayland, the ENABLE_WAYLAND will be
+dropped, the "return matches" clause will be considered the else
+statement of the "if (xfw_windowing_get() == _X11)", which is always
+false in this scenario. Thus, this function always reach end of
+function without any return values.
+
+While we're at it, fix the comment for the ENABLE_WAYLAND leg.
+---
+ settings/main.c | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/settings/main.c b/settings/main.c
+index 3a1ce17b..410a2d23 100644
+--- a/settings/main.c
++++ b/settings/main.c
+@@ -1740,8 +1740,11 @@ is_our_window(AppearancePanel *panel,
+ matches = TRUE;
+ }
+ // TODO: check window geometry?
++ } else
++#endif /* ENABLE_WAYLAND */
++ {
++ g_assert_not_reached();
+ }
+-#endif /* GTK_WINDOWING_WAYLAND */
+
+ return matches;
+ }
+--
+GitLab
+
diff --git a/xfce-base/xfdesktop/xfdesktop-4.19.0.ebuild b/xfce-base/xfdesktop/xfdesktop-4.19.0.ebuild
new file mode 100644
index 0000000..91cfb82
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.19.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfdesktop/start
+ https://gitlab.xfce.org/xfce/xfdesktop/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="libnotify +thunar wayland X"
+REQUIRED_USE="|| ( wayland X )"
+
+DEPEND="
+ >=x11-libs/cairo-1.16
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3[wayland?,X?]
+ x11-libs/libX11
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/garcon-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.13:=
+ >=xfce-base/libxfce4windowing-4.19.1:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? ( >=xfce-base/thunar-4.17.10:= )
+ wayland? ( >=gui-libs/gtk-layer-shell-0.7.0 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}/non-wayland.patch"
+)
+
+src_configure() {
+ local myconf=(
+ $(use_enable wayland)
+ $(use_enable wayland gtk-layer-shell)
+ $(use_enable X x11)
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}