summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-proxy/haproxy/Manifest3
-rw-r--r--net-proxy/haproxy/files/haproxy.confd14
-rw-r--r--net-proxy/haproxy/files/haproxy.initd-r685
-rw-r--r--net-proxy/haproxy/haproxy-9999.ebuild169
4 files changed, 0 insertions, 271 deletions
diff --git a/net-proxy/haproxy/Manifest b/net-proxy/haproxy/Manifest
deleted file mode 100644
index f210825..0000000
--- a/net-proxy/haproxy/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-AUX haproxy.confd 610 BLAKE2B 89c6ea0c2f623bbe7aa80a4f42de1d7fb38a2fa6e9edb5b9c758ee1c5140e750fa6be046e4854c94806a609bd3b487f2553bfeafb1db43871032731425b54f59 SHA512 80a6e109432c7e751e9e1063853f73d3269c4c3967728a90cf94230cb32308b396f9f9ad7795b74b919dae4f61e5a29a9ae7badf0908148accbe0e8ca2238913
-AUX haproxy.initd-r6 1705 BLAKE2B af8b9ad2fcb499d7fec97fe4210af8685a15881aa98634551bad8ec90bd2fe412a7af337fcb5f3ced7715433fb1d98fa175ecb83fa61108802973976109a7c6d SHA512 59693dfb0ae004559e57fb751ebd4abc85a982733699230ff51aa94a2bb7db9875bc63f6a03355b7434448736beb513e923b2ad9c70661f4110e4b2ad2bba753
-EBUILD haproxy-9999.ebuild 4856 BLAKE2B db66484f3c0a4b88b728886f67155ab0a76f494aea5313eb3b15b549868f84b68eb8d2d0b97efd8e88acb25e2938f45fc0d319f13bc61fb98b39cbacd7923909 SHA512 32739c0f2e595671b15e263a203d6d7ecad59adca43296f4a71a8232a87215feabd7322aa3c8874fdd3802c4f1b793c4db69ff8602a7ecc6c4c2848abf406ddf
diff --git a/net-proxy/haproxy/files/haproxy.confd b/net-proxy/haproxy/files/haproxy.confd
deleted file mode 100644
index 30739eb..0000000
--- a/net-proxy/haproxy/files/haproxy.confd
+++ /dev/null
@@ -1,14 +0,0 @@
-# HAProxy config file(s), space separated
-#CONFIGS="/etc/haproxy/haproxy.cfg"
-
-# Additional HAProxy command line options
-HAPROXY_OPTS=""
-
-# If you want to make use ot the new seamless reload you can just write your own
-# reload_seamless function here. It will be called by the init script.
-# For more information on how to use that feature please have a look at the
-# "seamless_reload.txt" documentation file (requires net-proxy/haproxy[examples])
-#reload_seamless() {
-# checkpath -d -m 0700 haproxy:haproxy "/run/haproxy/"
-# socat /run/haproxy/socket - <<< "show servers state" > /run/haproxy/global.state
-#}
diff --git a/net-proxy/haproxy/files/haproxy.initd-r6 b/net-proxy/haproxy/files/haproxy.initd-r6
deleted file mode 100644
index 9b7c5fe..0000000
--- a/net-proxy/haproxy/files/haproxy.initd-r6
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-extra_commands="checkconfig"
-extra_started_commands="reload"
-
-command="/usr/sbin/haproxy"
-
-pidfile="${HAPROXY_PIDFILE:-/run/${SVCNAME}.pid}"
-
-configs=
-
-if [ -z "${CONFIGS}" ]; then
- if [ -f "/etc/haproxy/${SVCNAME}.cfg" ]; then
- CONFIGS=/etc/haproxy/${SVCNAME}.cfg
- elif [ -f "/etc/${SVCNAME}.cfg" ]; then
- CONFIGS=/etc/${SVCNAME}.cfg # Deprecated
- fi
-fi
-
-for conf in $CONFIGS; do
- configs="${configs} -f ${conf}"
-done
-
-command_args="-D -p ${pidfile} ${configs} ${HAPROXY_OPTS}"
-
-depend() {
- need net
- use dns logger
-}
-
-checkconfig() {
- if [ -z "${CONFIGS}" ]; then
- eerror "No config(s) has been specified"
- return 1
- fi
-
- for conf in $CONFIGS; do
- if [ ! -f "${conf}" ]; then
- eerror "${conf} does not exist!"
- return 1
- fi
- done
-
- ebegin "Checking ${CONFIGS}"
- $command -q -c $configs $HAPROXY_OPTS
- eend $?
-}
-
-start_pre() {
- if [ "${RC_CMD}" != "restart" ]; then
- checkconfig || return 1
- fi
-}
-
-stop_pre() {
- if [ "${RC_CMD}" = "restart" ]; then
- checkconfig || return 1
- fi
-}
-
-stop() {
- local _t _pid
-
- _t="$(mktemp)"
- for _pid in $(cat ${pidfile}) ; do
- echo "${_pid}" > "${_t}"
- start-stop-daemon --stop --pidfile="${_t}"
- done
- rm -f "${_t}"
-}
-
-reload() {
- checkconfig || { eerror "Reloading failed, please fix your config(s) first"; return 1; }
-
- if [ "$(command -v reload_seamless)" = "reload_seamless" ]; then
- einfo "Calling user-defined reload_seamless()"
- reload_seamless || { eerror "reload_seamless() failed!"; return 1; }
- fi
-
- ebegin "Reloading ${SVCNAME}"
- $command -D -p "${pidfile}" $configs $HAPROXY_OPTS -sf $(cat "${pidfile}")
- eend $?
-}
diff --git a/net-proxy/haproxy/haproxy-9999.ebuild b/net-proxy/haproxy/haproxy-9999.ebuild
deleted file mode 100644
index 0e8b7f9..0000000
--- a/net-proxy/haproxy/haproxy-9999.ebuild
+++ /dev/null
@@ -1,169 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-[[ ${PV} == *9999 ]] && SCM="git-r3"
-inherit user versionator toolchain-funcs flag-o-matic systemd linux-info $SCM
-
-MY_P="${PN}-${PV/_beta/-dev}"
-
-DESCRIPTION="A TCP/HTTP reverse proxy for high availability environments"
-HOMEPAGE="http://www.haproxy.org"
-if [[ ${PV} != *9999 ]]; then
- SRC_URI="http://haproxy.1wt.eu/download/$(get_version_component_range 1-2)/src/${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~ppc ~x86"
-else
- EGIT_REPO_URI="http://git.haproxy.org/git/haproxy.git/"
- EGIT_BRANCH=master
-fi
-
-LICENSE="GPL-2 LGPL-2.1"
-SLOT="0"
-IUSE="+crypt doc examples libressl slz net_ns +pcre pcre-jit pcre2 pcre2-jit ssl
-systemd +threads tools vim-syntax +zlib lua device-atlas 51degrees wurfl"
-REQUIRED_USE="pcre-jit? ( pcre )
- pcre2-jit? ( pcre2 )
- pcre? ( !pcre2 )
- device-atlas? ( pcre )
- ?? ( slz zlib )"
-
-DEPEND="
- pcre? (
- dev-libs/libpcre
- pcre-jit? ( dev-libs/libpcre[jit] )
- )
- pcre2? (
- dev-libs/libpcre
- pcre2-jit? ( dev-libs/libpcre2[jit] )
- )
- ssl? (
- !libressl? ( dev-libs/openssl:0=[zlib?] )
- libressl? ( dev-libs/libressl:0= )
- )
- slz? ( dev-libs/libslz:= )
- zlib? ( sys-libs/zlib )
- lua? ( dev-lang/lua:5.3 )
- device-atlas? ( dev-libs/device-atlas-api-c )"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CHANGELOG CONTRIBUTING MAINTAINERS README )
-CONTRIBS=( halog iprange )
-# ip6range is present in 1.6, but broken.
-version_is_at_least 1.7.0 $PV && CONTRIBS+=( ip6range spoa_example tcploop )
-# TODO: mod_defender - requires apache / APR, modsecurity - the same
-version_is_at_least 1.8.0 $PV && CONTRIBS+=( hpack )
-
-haproxy_use() {
- (( $# != 2 )) && die "${FUNCNAME} <USE flag> <make option>"
-
- usex "${1}" "USE_${2}=1" "USE_${2}="
-}
-
-pkg_setup() {
- enewgroup haproxy
- enewuser haproxy -1 -1 -1 haproxy
-
- if use net_ns; then
- CONFIG_CHECK="~NET_NS"
- linux-info_pkg_setup
- fi
-}
-
-src_compile() {
- local -a args=(
- TARGET=linux-glibc
- USE_GETADDRINFO=1
- USE_TFO=1
- )
-
- # TODO: PCRE2_WIDTH?
- args+=( $(haproxy_use threads THREAD) )
- args+=( $(haproxy_use crypt LIBCRYPT) )
- args+=( $(haproxy_use net_ns NS) )
- args+=( $(haproxy_use pcre PCRE) )
- args+=( $(haproxy_use pcre-jit PCRE_JIT) )
- args+=( $(haproxy_use ssl OPENSSL) )
- args+=( $(haproxy_use slz SLZ) )
- args+=( $(haproxy_use zlib ZLIB) )
- args+=( $(haproxy_use lua LUA) )
- args+=( $(haproxy_use 51degrees 51DEGREES) )
- args+=( $(haproxy_use device-atlas DEVICEATLAS) )
- args+=( $(haproxy_use wurfl WURFL) )
- args+=( $(haproxy_use systemd SYSTEMD) )
-
- # For now, until the strict-aliasing breakage will be fixed
- append-cflags -fno-strict-aliasing
-
- emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
- emake -C contrib/systemd SBINDIR=/usr/sbin
-
- if use tools ; then
- for contrib in ${CONTRIBS[@]} ; do
- emake -C contrib/${contrib} \
- CFLAGS="${CFLAGS}" OPTIMIZE="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC=$(tc-getCC) ${args[@]}
- done
- fi
-}
-
-src_install() {
- dosbin haproxy
- dosym ../sbin/haproxy /usr/bin/haproxy
-
- newconfd "${FILESDIR}/${PN}.confd" $PN
- newinitd "${FILESDIR}/${PN}.initd-r6" $PN
-
- doman doc/haproxy.1
-
- systemd_dounit contrib/systemd/haproxy.service
-
- einstalldocs
-
- # The errorfiles are used by upstream defaults.
- insinto /etc/haproxy/errors/
- doins examples/errorfiles/*
-
- if use doc; then
- dodoc ROADMAP doc/*.txt
- #if use lua; then
- # TODO: doc/lua-api/
- #fi
- fi
-
- if use tools ; then
- has halog "${CONTRIBS[@]}" && dobin contrib/halog/halog
- has "iprange" "${CONTRIBS[@]}" && newbin contrib/iprange/iprange haproxy_iprange
- has "ip6range" "${CONTRIBS[@]}" && newbin contrib/ip6range/ip6range haproxy_ip6range
- has "spoa_example" "${CONTRIBS[@]}" && newbin contrib/spoa_example/spoa haproxy_spoa_example
- has "spoa_example" "${CONTRIBS[@]}" && newdoc contrib/spoa_example/README README.spoa_example
- has "tcploop" "${CONTRIBS[@]}" && newbin contrib/tcploop/tcploop haproxy_tcploop
- has "hpack" "${CONTRIBS[@]}" && newbin contrib/hpack/gen-rht haproxy_hpack
- fi
-
- if use examples ; then
- docinto examples
- dodoc examples/*.cfg
- dodoc examples/seamless_reload.txt
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/syntax
- doins examples/haproxy.vim
- fi
-}
-
-pkg_postinst() {
- if [[ ! -f "${EROOT}/etc/haproxy/haproxy.cfg" ]] ; then
- ewarn "You need to create /etc/haproxy/haproxy.cfg before you start the haproxy service."
- ewarn "It's best practice to not run haproxy as root, user and group haproxy was therefore created."
- ewarn "Make use of them with the \"user\" and \"group\" directives."
-
- if [[ -d "${EROOT}/usr/share/doc/${PF}" ]]; then
- einfo "Please consult the installed documentation for learning the configuration file's syntax."
- einfo "The documentation and sample configuration files are installed here:"
- einfo " ${EROOT}usr/share/doc/${PF}"
- fi
- fi
-}