summaryrefslogtreecommitdiff
path: root/x11-apps
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2014-10-20 19:33:34 +0200
committerMarcin Deranek <gringo@slonko.net>2014-10-20 19:33:34 +0200
commitefb37cbd90d419c913e6739206cfbcd6b905f2f7 (patch)
tree338c8cca3b9eee6360951135c018d5164dad4cc7 /x11-apps
parent0417d743d7414e7ea1c0a332a70d38037c2e9b8f (diff)
downloadportage-efb37cbd90d419c913e6739206cfbcd6b905f2f7.tar.gz
portage-efb37cbd90d419c913e6739206cfbcd6b905f2f7.tar.bz2
portage-efb37cbd90d419c913e6739206cfbcd6b905f2f7.zip
Added Bluetooth proximity app
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/blueproximity/Manifest2
-rw-r--r--x11-apps/blueproximity/blueproximity-1.2.5.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-apps/blueproximity/Manifest b/x11-apps/blueproximity/Manifest
new file mode 100644
index 0000000..c7dd2b2
--- /dev/null
+++ b/x11-apps/blueproximity/Manifest
@@ -0,0 +1,2 @@
+DIST blueproximity-1.2.5.tar.gz 301090 SHA256 d1211d7898792a6db8448768884970c0d5efe683c6aa2ffc13e765f7d5fb62d9 SHA512 d72f3d1b15538a31d0eced6627fc0dc16c7404be0ddfb3bf6d13c9a0a1b089e9f001d50a26e1a1d4015e07b0013e78001b2b204f94ef21cd0de49b42550b5436 WHIRLPOOL 130f0d3240383d07611a17a483b489d33f833a40d755c4caacd5fd9e0bc362610e739d5c5be51b58dbe83c5b8d2d18454a236be35eecc862c962390399b7820b
+EBUILD blueproximity-1.2.5.ebuild 1340 SHA256 7fb364c12980c9a363230e6eb42c0c61a1e8f3bd2c5a5fd5aae0b961dbf06370 SHA512 e98d81030f926fd29eb6e64956e9670d8390c9ee267fa0629885975c88d30b604538c372311e166824425f4b9160ba463baea9bce10912614684604be4d5c27b WHIRLPOOL c80ecbbd2c9b8795b1facec19461d77fa8573cd206ccd0ed2ccd570bea13d63a8229b1af982633d0d68f37d87766a082c6fc7ca74a7fbf03ffd2fa231dc90b6a
diff --git a/x11-apps/blueproximity/blueproximity-1.2.5.ebuild b/x11-apps/blueproximity/blueproximity-1.2.5.ebuild
new file mode 100644
index 0000000..125e932
--- /dev/null
+++ b/x11-apps/blueproximity/blueproximity-1.2.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils python-single-r1
+
+DESCRIPTION="Proximity detector for your mobile phone via bluetooth"
+HOMEPAGE="http://blueproximity.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+IUSE=""
+
+MY_AVAILABLE_LINGUAS="de en es fa hu it ru sv th"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+SLOT="0"
+
+LICENSE="GPL-2"
+
+KEYWORDS="~x86 ~amd64"
+
+DEPEND=""
+RDEPEND="dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/pybluez[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.0[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${P}.orig"
+
+src_install() {
+ sed -i -r "s:\`dirname \\\$PRG\`:/usr/lib/${PN}:" start_proximity.sh
+ sed -i "s#python #${PYTHON} #" start_proximity.sh
+ newbin start_proximity.sh blueproximity
+ insinto "/usr/lib/${PN}"
+ doins blueproximity*
+ doins proximity*
+ dodoc COPYING
+ dodoc README
+ dodoc ChangeLog
+ doman doc/blueproximity.1
+ dohtml doc/*
+ insinto /usr/share/applications
+ doins addons/blueproximity.desktop
+ insinto /usr/share/pixmaps
+ doins addons/blueproximity.xpm
+ strip-linguas ${MY_AVAILABLE_LINGUAS}
+ for l in ${LINGUAS};
+ do
+ dodir "/usr/lib/${PN}/LANG/${l}"
+ cp -r "${S}/LANG/${l}" "${D}/usr/lib/${PN}/LANG"
+ done
+}