summaryrefslogtreecommitdiff
path: root/www-apps/joomla/joomla-3.10.5.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2022-01-26 09:38:51 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2022-01-26 21:38:18 +0100
commitfc210da4fb8c27fba3af1bc998b1cd2762aa4e2e (patch)
tree13f4b729332ee2fdd732b79b258cf0ea76a67919 /www-apps/joomla/joomla-3.10.5.ebuild
parent1b76222c5d1a7365f90a1a0ffe4864a16880cc4c (diff)
downloadportage-fc210da4fb8c27fba3af1bc998b1cd2762aa4e2e.tar.gz
portage-fc210da4fb8c27fba3af1bc998b1cd2762aa4e2e.tar.bz2
portage-fc210da4fb8c27fba3af1bc998b1cd2762aa4e2e.zip
www-apps/joomla version bump to 3.10.5
Diffstat (limited to 'www-apps/joomla/joomla-3.10.5.ebuild')
-rw-r--r--www-apps/joomla/joomla-3.10.5.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/www-apps/joomla/joomla-3.10.5.ebuild b/www-apps/joomla/joomla-3.10.5.ebuild
new file mode 100644
index 0000000..dcded18
--- /dev/null
+++ b/www-apps/joomla/joomla-3.10.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit webapp
+
+MY_PV="${PV//_/-}"
+
+DESCRIPTION="A powerful Open Source Content Management System"
+HOMEPAGE="http://www.joomla.org/"
+M_PN="Joomla_${MY_PV}-Stable-Full_Package"
+SRC_URI="https://github.com/${PN}/${PN}-cms/releases/download/${MY_PV}/${M_PN}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+S="${WORKDIR}"
+need_httpd_cgi
+
+RDEPEND=">=dev-lang/php-5.3.10[json,zlib,xml]
+ virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[postgres] )"
+
+src_install () {
+ webapp_src_preinst
+
+ touch configuration.php
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local files=" administrator/cache administrator/components
+ administrator/language administrator/language/en-GB
+ administrator/manifests/packages
+ administrator/modules administrator/templates cache components images installation
+ images/banners language language/en-GB media modules plugins
+ plugins/authentication plugins/content plugins/editors plugins/editors-xtd
+ plugins/search plugins/system plugins/user plugins tmp templates"
+
+ for file in ${files}; do
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/${file}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/configuration.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/configuration.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postinst_txt sv "${FILESDIR}"/postinstall-sv.txt
+ webapp_src_install
+}