summaryrefslogtreecommitdiff
path: root/www-apps/joomla/joomla-3.10.11.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2022-10-25 18:06:47 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2022-10-25 18:06:47 +0200
commitab78ca9e9586e05bf24259b1d0695181cb1c9f9d (patch)
tree87fc0bdde941651ee96314f81f0cfe19e725b4fb /www-apps/joomla/joomla-3.10.11.ebuild
parentebcd38e646a8c9b29d07d52430204a912410efde (diff)
downloadportage-ab78ca9e9586e05bf24259b1d0695181cb1c9f9d.tar.gz
portage-ab78ca9e9586e05bf24259b1d0695181cb1c9f9d.tar.bz2
portage-ab78ca9e9586e05bf24259b1d0695181cb1c9f9d.zip
www-apps/joomla version bump
Diffstat (limited to 'www-apps/joomla/joomla-3.10.11.ebuild')
-rw-r--r--www-apps/joomla/joomla-3.10.11.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/www-apps/joomla/joomla-3.10.11.ebuild b/www-apps/joomla/joomla-3.10.11.ebuild
new file mode 100644
index 0000000..943041b
--- /dev/null
+++ b/www-apps/joomla/joomla-3.10.11.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit webapp
+
+MY_PV="${PV//_/-}"
+
+DESCRIPTION="A powerful Open Source Content Management System"
+HOMEPAGE="https://www.joomla.org/"
+M_PN="Joomla_${MY_PV}-Stable-Full_Package"
+SRC_URI="https://github.com/${PN}/${PN}-cms/releases/download/${MY_PV}/${M_PN}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+S="${WORKDIR}"
+need_httpd_cgi
+
+RDEPEND=">=dev-lang/php-5.3.10[json(+),zlib,xml]
+ virtual/httpd-php
+ || ( dev-lang/php[mysql] dev-lang/php[postgres] )"
+
+src_install () {
+ webapp_src_preinst
+
+ touch configuration.php
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ local files=" administrator/cache administrator/components
+ administrator/language administrator/language/en-GB
+ administrator/manifests/packages
+ administrator/modules administrator/templates cache components images installation
+ images/banners language language/en-GB media modules plugins
+ plugins/authentication plugins/content plugins/editors plugins/editors-xtd
+ plugins/search plugins/system plugins/user plugins tmp templates"
+
+ for file in ${files}; do
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/${file}
+ done
+
+ webapp_configfile "${MY_HTDOCSDIR}"/configuration.php
+ webapp_serverowned "${MY_HTDOCSDIR}"/configuration.php
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+ webapp_postinst_txt sv "${FILESDIR}"/postinstall-sv.txt
+ webapp_src_install
+}