summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.9.6.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2020-11-06 09:43:48 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2020-11-06 09:48:48 +0100
commitf7653792d1a2a79801fdf695972a55070c41e9cb (patch)
tree65ef87735d8998595e1cdd6c32571487d0e94e75 /sys-kernel/hardened-sources/hardened-sources-5.9.6.ebuild
parentcae37b4c00cae0ff86d7e270ef978faa0a93518e (diff)
downloadportage-f7653792d1a2a79801fdf695972a55070c41e9cb.tar.gz
portage-f7653792d1a2a79801fdf695972a55070c41e9cb.tar.bz2
portage-f7653792d1a2a79801fdf695972a55070c41e9cb.zip
Version bump
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.9.6.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.9.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.9.6.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.9.6.ebuild
new file mode 100644
index 0000000..5017a95
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.9.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="6"
+K_NODRYRUN="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="a"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}.${SUBREL}/linux-hardened-${PV}.${SUBREL}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://github.com/anthraxx/linux-hardened https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+UNIPATCH_LIST="${DISTDIR}/linux-hardened-${PV}.${SUBREL}.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}