summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.9.15.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2020-12-17 17:08:39 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2020-12-17 17:08:39 +0100
commitee75c586f264703bc356b89c98c44e5c5c22e80e (patch)
tree8127b0ecf0321c5a948f5d5eb545ebbd4993b8d3 /sys-kernel/hardened-sources/hardened-sources-5.9.15.ebuild
parent7e6a53187643bb769ca30dcf967b01db48875cf4 (diff)
downloadportage-ee75c586f264703bc356b89c98c44e5c5c22e80e.tar.gz
portage-ee75c586f264703bc356b89c98c44e5c5c22e80e.tar.bz2
portage-ee75c586f264703bc356b89c98c44e5c5c22e80e.zip
Version bump
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.9.15.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.9.15.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.9.15.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.9.15.ebuild
new file mode 100644
index 0000000..cbf55d6
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.9.15.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="15"
+K_NODRYRUN="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="a"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}.${SUBREL}/linux-hardened-${PV}.${SUBREL}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://github.com/anthraxx/linux-hardened https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+UNIPATCH_LIST="${DISTDIR}/linux-hardened-${PV}.${SUBREL}.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}