summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.9.12.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2020-12-03 11:32:49 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2020-12-03 11:32:55 +0100
commit7e6a53187643bb769ca30dcf967b01db48875cf4 (patch)
tree46ff3ee9c527e203fd8d28a160539aa81e30e08d /sys-kernel/hardened-sources/hardened-sources-5.9.12.ebuild
parentc811821f5e79e903f18e6d6425cef9f95ad79854 (diff)
downloadportage-7e6a53187643bb769ca30dcf967b01db48875cf4.tar.gz
portage-7e6a53187643bb769ca30dcf967b01db48875cf4.tar.bz2
portage-7e6a53187643bb769ca30dcf967b01db48875cf4.zip
Version bump
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.9.12.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.9.12.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.9.12.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.9.12.ebuild
new file mode 100644
index 0000000..5f39523
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.9.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="12"
+K_NODRYRUN="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="a"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}.${SUBREL}/linux-hardened-${PV}.${SUBREL}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://github.com/anthraxx/linux-hardened https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+UNIPATCH_LIST="${DISTDIR}/linux-hardened-${PV}.${SUBREL}.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}