summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.4.43.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2020-05-29 14:56:49 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2020-05-29 14:56:53 +0200
commit5d06540d54231dd691b64ad700504fbabc61800b (patch)
tree4c3f4b678d77bc6c18fc5c128528179cb4825291 /sys-kernel/hardened-sources/hardened-sources-5.4.43.ebuild
parente259f0cf22812a7b76c9bfc51dd84d77a5fe50fa (diff)
downloadportage-5d06540d54231dd691b64ad700504fbabc61800b.tar.gz
portage-5d06540d54231dd691b64ad700504fbabc61800b.tar.bz2
portage-5d06540d54231dd691b64ad700504fbabc61800b.zip
Version bump
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.4.43.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.4.43.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.4.43.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.4.43.ebuild
new file mode 100644
index 0000000..4800c86
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.4.43.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="43"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="b"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}.${SUBREL}/linux-hardened-${PV}.${SUBREL}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://github.com/anthraxx/linux-hardened"
+IUSE="experimental"
+UNIPATCH_LIST="${DISTDIR}/linux-hardened-${PV}.${SUBREL}.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}