summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.4.28.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2020-03-30 16:48:15 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2020-03-30 16:51:08 +0200
commite3adbfb56bbd64c13246e58805aa20b761cc65ff (patch)
tree2571d4330cda28913f8a0c564a0314867ccaa6e6 /sys-kernel/hardened-sources/hardened-sources-5.4.28.ebuild
parent361de922c2489ddbd711a2519203b39e94ad1f8f (diff)
downloadportage-e3adbfb56bbd64c13246e58805aa20b761cc65ff.tar.gz
portage-e3adbfb56bbd64c13246e58805aa20b761cc65ff.tar.bz2
portage-e3adbfb56bbd64c13246e58805aa20b761cc65ff.zip
Version bump
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.4.28.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.4.28.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.4.28.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.4.28.ebuild
new file mode 100644
index 0000000..3cc0b69
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.4.28.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="28"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="a"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}.${SUBREL}/linux-hardened-${PV}.${SUBREL}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://github.com/anthraxx/linux-hardened"
+IUSE="experimental"
+UNIPATCH_LIST="${DISTDIR}/linux-hardened-${PV}.${SUBREL}.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}