summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.4.229.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2023-01-19 09:04:28 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2023-01-19 09:04:28 +0100
commit5d423d0c571d41af9fb4524064bbc5cf6082c62b (patch)
treed1d3038efc2fb31c9d6eb29ddcbbb443d2c76cdd /sys-kernel/hardened-sources/hardened-sources-5.4.229.ebuild
parent79c68606f0f776fc4f5cbc0acbd47c353fb195fc (diff)
downloadportage-5d423d0c571d41af9fb4524064bbc5cf6082c62b.tar.gz
portage-5d423d0c571d41af9fb4524064bbc5cf6082c62b.tar.bz2
portage-5d423d0c571d41af9fb4524064bbc5cf6082c62b.zip
sys-kernel/hardened-sources version bumps
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.4.229.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.4.229.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.4.229.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.4.229.ebuild
new file mode 100644
index 0000000..ffada6a
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.4.229.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="234"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="hardened1"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}-${SUBREL}/linux-hardened-${PV}-${SUBREL}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches https://github.com/anthraxx/linux-hardened"
+IUSE="experimental"
+UNIPATCH_LIST="${DISTDIR}/linux-hardened-${PV}-${SUBREL}.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}