summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.4.13.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2020-01-19 18:16:17 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2020-01-19 18:16:17 +0100
commitb8250dfce99fd359a3c2a585c1a746a312f850e7 (patch)
tree358451c11cd8baf6ad89b271903b2749f5a800c9 /sys-kernel/hardened-sources/hardened-sources-5.4.13.ebuild
parent024b9d0a361bf0a2e1c7f0643e6fc5b0f3741cd8 (diff)
downloadportage-b8250dfce99fd359a3c2a585c1a746a312f850e7.tar.gz
portage-b8250dfce99fd359a3c2a585c1a746a312f850e7.tar.bz2
portage-b8250dfce99fd359a3c2a585c1a746a312f850e7.zip
Version bump
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.4.13.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.4.13.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.4.13.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.4.13.ebuild
new file mode 100644
index 0000000..a418750
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.4.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="13"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="a"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}.${SUBREL}/linux-hardened-${PV}.${SUBREL}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+HOMEPAGE="https://github.com/anthraxx/linux-hardened"
+IUSE="experimental"
+UNIPATCH_LIST="${DISTDIR}/linux-hardened-${PV}.${SUBREL}.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}