summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.15.59.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2022-10-01 11:56:34 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2022-10-01 11:56:34 +0200
commit45a8e8da43ea7f6908002410d21641cc56b7e58d (patch)
tree413475bddb068112eb0a31f69ad247ce2ac773c8 /sys-kernel/hardened-sources/hardened-sources-5.15.59.ebuild
parent6704b04372145ca9b594c784ee41b156a956c075 (diff)
downloadportage-45a8e8da43ea7f6908002410d21641cc56b7e58d.tar.gz
portage-45a8e8da43ea7f6908002410d21641cc56b7e58d.tar.bz2
portage-45a8e8da43ea7f6908002410d21641cc56b7e58d.zip
sys-kernel/hardened-sources versions bump
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.15.59.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.15.59.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.15.59.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.15.59.ebuild
new file mode 100644
index 0000000..ecf5677
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.15.59.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="63"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="hardened1"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}-${SUBREL}/linux-hardened-${PV}-${SUBREL}.patch"
+
+KEYWORDS="hppa"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches https://github.com/anthraxx/linux-hardened"
+IUSE="experimental"
+UNIPATCH_LIST="${FILESDIR}/9999_revert-conflicts-v1.patch ${DISTDIR}/linux-hardened-${PV}-${SUBREL}.patch ${FILESDIR}/linux-hardened-gentoo-v1.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}