summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.15.166.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2024-09-07 23:10:19 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2024-09-07 23:10:26 +0200
commite270721f30cf67d94b6373eecab8e924f17bc89c (patch)
treee6b85f7e8e06648b9491c2bf85db18ce2bd07cd4 /sys-kernel/hardened-sources/hardened-sources-5.15.166.ebuild
parent569904975827d717931355c70303bb82566e1583 (diff)
downloadportage-e270721f30cf67d94b6373eecab8e924f17bc89c.tar.gz
portage-e270721f30cf67d94b6373eecab8e924f17bc89c.tar.bz2
portage-e270721f30cf67d94b6373eecab8e924f17bc89c.zip
sys-kernel/hardened-sources Version bumps
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.15.166.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.15.166.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.15.166.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.15.166.ebuild
new file mode 100644
index 0000000..87a92c6
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.15.166.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="176"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="hardened1"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/v${PV%.0}-${SUBREL}/linux-hardened-v${PV%.0}-${SUBREL}.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches https://github.com/anthraxx/linux-hardened"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="experimental"
+UNIPATCH_LIST="${FILESDIR}/9999_revert-conflicts-v1.patch ${DISTDIR}/linux-hardened-v${PV%.0}-${SUBREL}.patch ${FILESDIR}/linux-hardened-gentoo-v1.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}