summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.10.8.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2021-01-19 17:45:22 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2021-01-19 17:45:22 +0100
commit75c913d25875a405e96aa62e406fcd86309e3089 (patch)
treecd270779e5ed83ae6fbe203df4848a0a346a146b /sys-kernel/hardened-sources/hardened-sources-5.10.8.ebuild
parentf36e5ee188294e8146cc3d0ac45bcde360b6293c (diff)
downloadportage-75c913d25875a405e96aa62e406fcd86309e3089.tar.gz
portage-75c913d25875a405e96aa62e406fcd86309e3089.tar.bz2
portage-75c913d25875a405e96aa62e406fcd86309e3089.zip
[sys-kernel/hardened-sources] Version bump
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.10.8.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.10.8.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.10.8.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.10.8.ebuild
new file mode 100644
index 0000000..262db65
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.10.8.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="10"
+K_NODRYRUN="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="a"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}.${SUBREL}/linux-hardened-${PV}.${SUBREL}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://github.com/anthraxx/linux-hardened https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+UNIPATCH_LIST="${DISTDIR}/linux-hardened-${PV}.${SUBREL}.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}