summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.10.6.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2021-01-12 09:39:28 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2021-01-12 09:39:28 +0100
commit6da90b5ba639a037c41c9190caeb25e6a9107a98 (patch)
tree591b76b291920d041cbc505d1ff45f10f3cc2671 /sys-kernel/hardened-sources/hardened-sources-5.10.6.ebuild
parentd911f5fe525d782d3531b6b95a7ae6e3215ff50f (diff)
downloadportage-6da90b5ba639a037c41c9190caeb25e6a9107a98.tar.gz
portage-6da90b5ba639a037c41c9190caeb25e6a9107a98.tar.bz2
portage-6da90b5ba639a037c41c9190caeb25e6a9107a98.zip
Version bump
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.10.6.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.10.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.10.6.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.10.6.ebuild
new file mode 100644
index 0000000..8572a43
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.10.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="8"
+K_NODRYRUN="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="a"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}.${SUBREL}/linux-hardened-${PV}.${SUBREL}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+HOMEPAGE="https://github.com/anthraxx/linux-hardened https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+UNIPATCH_LIST="${DISTDIR}/linux-hardened-${PV}.${SUBREL}.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}