summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.10.26.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2021-03-26 21:41:09 +0100
committerMarcin Deranek <marcin.deranek@slonko.net>2021-03-26 21:41:09 +0100
commitcc09f10586f75becf9c382ab2c210d32a46bebbf (patch)
treebe757b19e3a0b940c3f740bfb430b4dbe44c4835 /sys-kernel/hardened-sources/hardened-sources-5.10.26.ebuild
parent689d661dae0436b43bace6881ce6c7e50666bf13 (diff)
downloadportage-cc09f10586f75becf9c382ab2c210d32a46bebbf.tar.gz
portage-cc09f10586f75becf9c382ab2c210d32a46bebbf.tar.bz2
portage-cc09f10586f75becf9c382ab2c210d32a46bebbf.zip
hardened-sources version bumps
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.10.26.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.10.26.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.10.26.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.10.26.ebuild
new file mode 100644
index 0000000..c386bd6
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.10.26.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="29"
+K_NODRYRUN="1"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="hardened1"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}-${SUBREL}/linux-hardened-${PV}-${SUBREL}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://github.com/anthraxx/linux-hardened https://dev.gentoo.org/~mpagano/genpatches"
+IUSE="experimental"
+UNIPATCH_LIST="${DISTDIR}/linux-hardened-${PV}-${SUBREL}.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}