summaryrefslogtreecommitdiff
path: root/sys-kernel/hardened-sources/hardened-sources-5.10.134.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2022-08-01 14:05:56 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2022-08-01 14:05:56 +0200
commit6d7843ee80ca045947819306f467ea7f8332c4b6 (patch)
tree907cd06e05eee9760e1bef11d41f73c568677f6a /sys-kernel/hardened-sources/hardened-sources-5.10.134.ebuild
parentb4e63c9feacc6e41889620919c839a98a6aa0028 (diff)
downloadportage-6d7843ee80ca045947819306f467ea7f8332c4b6.tar.gz
portage-6d7843ee80ca045947819306f467ea7f8332c4b6.tar.bz2
portage-6d7843ee80ca045947819306f467ea7f8332c4b6.zip
sys-kernel/hardened-sources versions bump
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-5.10.134.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-5.10.134.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-5.10.134.ebuild b/sys-kernel/hardened-sources/hardened-sources-5.10.134.ebuild
new file mode 100644
index 0000000..979f62e
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-5.10.134.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="143"
+
+inherit kernel-2
+detect_version
+detect_arch
+SUBREL="hardened1"
+HARDENED_URI="https://github.com/anthraxx/linux-hardened/releases/download/${PV}-${SUBREL}/linux-hardened-${PV}-${SUBREL}.patch"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches https://github.com/anthraxx/linux-hardened"
+IUSE="experimental"
+UNIPATCH_LIST="${FILESDIR}/9999_revert-conflicts-v1.patch ${DISTDIR}/linux-hardened-${PV}-${SUBREL}.patch ${FILESDIR}/linux-hardened-gentoo-v1.patch"
+UNIPATCH_EXCLUDE="1510_fs-enable-link-security-restrictions-by-default.patch"
+
+DESCRIPTION="Minimal supplement to upstream Kernel Self Protection Project"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${HARDENED_URI} ${ARCH_URI}"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ einfo "For more info on this patchset, and how to report problems, see:"
+ einfo "${HOMEPAGE}"
+}
+
+pkg_postrm() {
+ kernel-2_pkg_postrm
+}