summaryrefslogtreecommitdiff
path: root/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2022-02-08 12:16:30 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2022-02-08 12:16:36 +0100
commit5d89846568c18a805142e7a0588c2886c5a53b74 (patch)
tree8bbd5540520a68c8dc9528a6aeecdb0b6ebbe8df /net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild
parent46aec12fcbd6c8239c5239b21bc2c385ffb6f15e (diff)
downloadportage-5d89846568c18a805142e7a0588c2886c5a53b74.tar.gz
portage-5d89846568c18a805142e7a0588c2886c5a53b74.tar.bz2
portage-5d89846568c18a805142e7a0588c2886c5a53b74.zip
Initial version for gp-saml-gui
Diffstat (limited to 'net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild')
-rw-r--r--net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild b/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild
new file mode 100644
index 0000000..b2e6259
--- /dev/null
+++ b/net-vpn/gp-saml-gui/gp-saml-gui-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Interactively authenticate to GlobalProtect VPNs that require SAML"
+HOMEPAGE="https://github.com/dlenski/gp-saml-gui"
+
+EGIT_REPO_URI="https://github.com/dlenski/gp-saml-gui.git"
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ net-libs/webkit-gtk
+"