summaryrefslogtreecommitdiff
path: root/net-mail/mhonarc
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2022-12-30 11:17:47 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2022-12-30 11:20:31 +0100
commitaa66e62780b8e7dc2c6cc1fe283d98d837667341 (patch)
treeb6c464ffd7c845f1c23d0410c0c81bde1869fd83 /net-mail/mhonarc
parent3cbaea8952353b6668cb1134a5dab8c410c7c778 (diff)
downloadportage-aa66e62780b8e7dc2c6cc1fe283d98d837667341.tar.gz
portage-aa66e62780b8e7dc2c6cc1fe283d98d837667341.tar.bz2
portage-aa66e62780b8e7dc2c6cc1fe283d98d837667341.zip
net-mail/sympa version bump along with net-mail/mhonarc
Diffstat (limited to 'net-mail/mhonarc')
-rw-r--r--net-mail/mhonarc/Manifest3
-rw-r--r--net-mail/mhonarc/metadata.xml12
-rw-r--r--net-mail/mhonarc/mhonarc-2.6.24.ebuild32
3 files changed, 47 insertions, 0 deletions
diff --git a/net-mail/mhonarc/Manifest b/net-mail/mhonarc/Manifest
new file mode 100644
index 0000000..9962087
--- /dev/null
+++ b/net-mail/mhonarc/Manifest
@@ -0,0 +1,3 @@
+DIST mhonarc-2.6.24.tar.gz 1955519 BLAKE2B fb657c01b3f71cd1b90d50dc213f490d72312083ae3c174d832591715c086206901bc1660ae9987ff7c5bdb7c131bc151923e5ce3086267a8887b663ef97da02 SHA512 bb3c4ee7c5dfd731513f1f7e4bcc92d0ae437975048c297812c93b3571fc560eb87ce60a929aa2fef0e2f1c9ad7a1ce3f3520d4724d3803f89c70e5869199b41
+EBUILD mhonarc-2.6.24.ebuild 908 BLAKE2B ecc235f4b11f01289ae19bd72d971b70e687a2f25083fa14c8007d49418faa0592299f0f786946591f597018a41c1c6acaabbacded35cb16a3e8b6c561f1c0ed SHA512 4665b25736eb5e708b05b6a8fef8d90b2eab4b4662bec7db04eb3e3ae591b3a4d0148b891a88c553ade46a26746911491b0a540f6179d03f5e743a58b6980d78
+MISC metadata.xml 414 BLAKE2B 9701c6503f74e845291dc0c13f4e35fa2ce4372bf487870c3a2b644c30384a815950c2d703e4d1057bc52f65bcaace47d30251d7befd67ab5b25a9c928032f5f SHA512 70f498ccfc04c5fc6f1e1c760d4dee79d0759038b6e9fb3228ed4e292dd14f4f4a20f9045368f94858ae231ab1c4ebbd0aab66ae17e6ef312a1d626eb25ba235
diff --git a/net-mail/mhonarc/metadata.xml b/net-mail/mhonarc/metadata.xml
new file mode 100644
index 0000000..f839628
--- /dev/null
+++ b/net-mail/mhonarc/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/sympa-community/MHonArc/issues</bugs-to>
+ <remote-id type="github">sympa-community/MHonArc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-mail/mhonarc/mhonarc-2.6.24.ebuild b/net-mail/mhonarc/mhonarc-2.6.24.ebuild
new file mode 100644
index 0000000..ce77008
--- /dev/null
+++ b/net-mail/mhonarc/mhonarc-2.6.24.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Perl Mail-to-HTML Converter"
+HOMEPAGE="https://www.mhonarc.org/"
+SRC_URI="https://github.com/sympa-community/MHonArc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ~ppc x86"
+# Warrants IUSE examples, and here it is + ? IUSE doc; see also extras folder with html docs
+IUSE="examples"
+
+S="${WORKDIR}/${P/mhonarc/MHonArc}"
+mydoc="README.txt"
+
+src_install() {
+ sed -e "s|-prefix |-docpath '${D}/usr/share/doc/${PF}/html' -prefix '${D}'|g" -i Makefile ||
+ die 'sed on Makefile failed'
+ sed -e "s|installsitelib|installvendorlib|g" -i install.me ||
+ die 'sed on install.me failed'
+ perl-module_src_install
+ if use examples; then
+ docompress -x usr/share/doc/${PF}/examples
+ insinto usr/share/doc/${PF}/
+ doins -r examples/
+ fi
+}