summaryrefslogtreecommitdiff
path: root/media-tv
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@slonko.net>2014-09-29 09:02:24 +0200
committerMarcin Deranek <marcin.deranek@slonko.net>2014-09-29 09:02:24 +0200
commit103cf8b2ebc990a52011b7b0adeab45dc63ee99d (patch)
tree8cf2d2fef53dd6a17ed142614ccc255f3db29246 /media-tv
downloadportage-103cf8b2ebc990a52011b7b0adeab45dc63ee99d.tar.gz
portage-103cf8b2ebc990a52011b7b0adeab45dc63ee99d.tar.bz2
portage-103cf8b2ebc990a52011b7b0adeab45dc63ee99d.zip
Initial commit
Diffstat (limited to 'media-tv')
-rw-r--r--media-tv/sopcast/Manifest2
-rw-r--r--media-tv/sopcast/sopcast-3.0.1.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/media-tv/sopcast/Manifest b/media-tv/sopcast/Manifest
new file mode 100644
index 0000000..107b8f2
--- /dev/null
+++ b/media-tv/sopcast/Manifest
@@ -0,0 +1,2 @@
+DIST sp-auth.tgz 340562 RMD160 8cb986e50a27b1d77c0156e7b8a287de7ce4cd21 SHA1 948e2b1d1e8c05d679ee45830812d2a5bde5d5d8 SHA256 68595a011e7c359bc36106e4f4ea390087975677ccdae6e87e5280b292b4f930
+EBUILD sopcast-3.0.1.ebuild 1084 RMD160 faaf910b43855123a8933c96e00eaf7a8c4d23a5 SHA1 9bb501eca32e5a2a98ccb8d517131086b9d1e999 SHA256 f3d5bd74b689475aa0df125bf1bd3fb6a81a26f6ce27eafbf7a838e8f86c81d0
diff --git a/media-tv/sopcast/sopcast-3.0.1.ebuild b/media-tv/sopcast/sopcast-3.0.1.ebuild
new file mode 100644
index 0000000..71620a4
--- /dev/null
+++ b/media-tv/sopcast/sopcast-3.0.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils
+RESTRICT="nomirror"
+
+MY_P="sp-auth"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="SopCast free P2P Internet TV binary"
+LICENSE="SopCast-unknown-license"
+HOMEPAGE="http://www.sopcast.com/"
+SRC_URI="http://download.sopcast.cn/download/${MY_P}.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+# All dependencies might not be listed, since the binary blob's homepage only lists libstdc++
+RDEPEND="amd64? ( app-emulation/emul-linux-x86-compat )
+ x86? ( >=virtual/libstdc++-3.3 )"
+
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ ewarn "SopCast binary blob is distributed without version info in its package."
+ ewarn "Thus, in case this ebuild fails, you might want to remove your " $MY_SRC
+ ewarn "from /usr/portage/distfiles and check whether they have release a newer"
+ ewarn "version on their homepage at"
+ ewarn $HOMEPAGE
+
+ unpack ${A}
+}
+
+src_install() {
+ exeinto /opt/${PN}
+ doexe sp-sc-auth
+ dosym /opt/${PN}/sp-sc-auth /usr/bin/sp-sc
+ dodoc Readme
+}