summaryrefslogtreecommitdiff
path: root/media-gfx/iscan-plugin-network-nt
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2020-03-08 02:21:01 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2020-03-08 02:21:08 +0100
commit79e74c3e3601b76cd95d1c8c40f6d6e4040287de (patch)
tree20bc768ff0b5cf42901029dadcc3d87b4e6c45ab /media-gfx/iscan-plugin-network-nt
parentf2d6850816ca373475f9fd08c40bc47a511b60e6 (diff)
downloadportage-79e74c3e3601b76cd95d1c8c40f6d6e4040287de.tar.gz
portage-79e74c3e3601b76cd95d1c8c40f6d6e4040287de.tar.bz2
portage-79e74c3e3601b76cd95d1c8c40f6d6e4040287de.zip
Epson scanning software
Diffstat (limited to 'media-gfx/iscan-plugin-network-nt')
-rw-r--r--media-gfx/iscan-plugin-network-nt/Manifest2
-rw-r--r--media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/iscan-plugin-network-nt/Manifest b/media-gfx/iscan-plugin-network-nt/Manifest
new file mode 100644
index 0000000..b623ca1
--- /dev/null
+++ b/media-gfx/iscan-plugin-network-nt/Manifest
@@ -0,0 +1,2 @@
+DIST imagescan-bundle-centos-8-3.62.0.x64.rpm.tar.gz 11111201 BLAKE2B 51b868569fa049f8bc35a911245895c0fe0c5e0060b129c1c84a39cddd0aa4344ea024b6896dadc535438bcfc0be74337348533adf1b2be8866aad4e30bcb41a SHA512 11af49d20fc8e828c25dc6e912d1dbefebcba9835b1ebe922bc57c30dd0d13b79508a1bb01ad260c721d865fd393a41bc2bf41dc84b42efb22512a28cc9542f3
+EBUILD iscan-plugin-network-nt-1.1.3.ebuild 1085 BLAKE2B 44ceb2a647d5d66826c6f8854611ac67842629f292dd1782e8054be1674880aa65ae1712e5bd0d2acccb301d45ca1f19dc276546fa5011ae264be9a77e361063 SHA512 677d62fa277f19c151f0ffee8809c25b799d3a129717e1f8d5c52cee22e10bbb6ecba68d19623cdcd2094158ee05a9dc114f705f75a1dd3ec4f9e7e2c7c9f25f
diff --git a/media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild b/media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild
new file mode 100644
index 0000000..5c9a1f3
--- /dev/null
+++ b/media-gfx/iscan-plugin-network-nt/iscan-plugin-network-nt-1.1.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info rpm
+
+DESCRIPTION="Network scanning plugin for EPSON scanners (nonfree)"
+
+HOMEPAGE="http://download.ebz.epson.net/dsc/search/01/search/?OSC=LX"
+# This is distributed as part of the "bundle driver"; since we already have the
+# opensource part separately we just install the nonfree part here.
+
+ISCAN_VERSION="3.62.0"
+
+SRC_URI="https://download2.ebz.epson.net/imagescanv3/centos/latest1/rpm/x64/imagescan-bundle-centos-8-${ISCAN_VERSION}.x64.rpm.tar.gz"
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="media-gfx/iscan"
+RESTRICT="bindist mirror strip"
+CONFIG_CHECK="~SYN_COOKIES"
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ rpm_unpack ./imagescan-bundle-centos-8-${ISCAN_VERSION}.x64.rpm/plugins/imagescan-plugin-networkscan-${PV}-1epson4centos8.x86_64.rpm
+}
+
+src_install() {
+ exeinto /usr/libexec/utsushi
+ doexe usr/libexec/utsushi/networkscan
+
+ gunzip usr/share/doc/imagescan-plugin-networkscan/*.gz
+ dodoc usr/share/doc/imagescan-plugin-networkscan/*
+}