summaryrefslogtreecommitdiff
path: root/media-gfx/epsonscan2
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2022-01-26 00:46:20 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2022-01-26 00:46:27 +0100
commit2cfdc4684a0e08516d18017834423a77e49290d4 (patch)
treea2e3bde06647270a6215ad34f78cde907f2471a2 /media-gfx/epsonscan2
parentb85133628de37a139818b5d819170455372d70e6 (diff)
downloadportage-2cfdc4684a0e08516d18017834423a77e49290d4.tar.gz
portage-2cfdc4684a0e08516d18017834423a77e49290d4.tar.bz2
portage-2cfdc4684a0e08516d18017834423a77e49290d4.zip
Initial build of epsonscan2 with plugins
Diffstat (limited to 'media-gfx/epsonscan2')
-rw-r--r--media-gfx/epsonscan2/Manifest3
-rw-r--r--media-gfx/epsonscan2/epsonscan2-6.6.40.0.ebuild45
-rw-r--r--media-gfx/epsonscan2/metadata.xml15
3 files changed, 63 insertions, 0 deletions
diff --git a/media-gfx/epsonscan2/Manifest b/media-gfx/epsonscan2/Manifest
new file mode 100644
index 0000000..2e27085
--- /dev/null
+++ b/media-gfx/epsonscan2/Manifest
@@ -0,0 +1,3 @@
+DIST epsonscan2-6.6.40.0-1.src.tar.gz 2289979 BLAKE2B f167ae9bdc52cafaf7eaf91f6e413e4b68f184d6d47bd38bcd9a12600a242dcf3311503716272ab13679600e6c6c080386645f65c948f5808722f325264d47c7 SHA512 004dcda54ab55f7370cfb86089b71c33155bc83e862fafd93204c1b43581c00fb078911abd9d1730fbb29e29bd679721aa31bbb165ffa7d0a5d5d39c003e385e
+EBUILD epsonscan2-6.6.40.0.ebuild 1043 BLAKE2B 547da45183ae5748e6b87ed489bebe98a7e944f9d31397ce5753152dabb74b2005bb4a5c92d819f5f271fe08e55816b653084470cfade7b94ea8957fd9d9b934 SHA512 06e56b921ca8da8df4c603c67deaac9d61c8e92a574e46adf925106eae5b54156641c1da99286f43000a0fdb81eb634923cd53c9255dfa09092f6958aaf40264
+MISC metadata.xml 720 BLAKE2B e78c658da4401d03c37ba710baf1b13048955c19899e8a44221a4dfb9d225a28f34afe0d4383767b67ce443531f513f8ae29591076244f38aa3485b96e4a49c3 SHA512 2a7f36915b53a80eef9242d062aa668b1a5ac0baec53108f68f2a47f544c34883d92ca8dd7baed653a794cc446fbcddea0327404d0ddf06633c8ff76106f0f71
diff --git a/media-gfx/epsonscan2/epsonscan2-6.6.40.0.ebuild b/media-gfx/epsonscan2/epsonscan2-6.6.40.0.ebuild
new file mode 100644
index 0000000..8cb6d77
--- /dev/null
+++ b/media-gfx/epsonscan2/epsonscan2-6.6.40.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_VERSION="${PV}-1"
+
+DESCRIPTION="Epson scanner management utility"
+HOMEPAGE="https://support.epson.net/linux/en/epsonscan2.php"
+SRC_URI="https://support.epson.net/linux/src/scanner/${PN}/${PN}-${MY_VERSION}.src.tar.gz"
+S="${WORKDIR}/${PN}-${MY_VERSION}"
+
+inherit cmake
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/boost
+ dev-libs/rapidjson
+ media-gfx/sane-backends
+ media-libs/libharu
+ media-libs/libpng
+ media-libs/tiff
+ virtual/jpeg
+ virtual/libusb:1
+"
+# dev-qt/qtsingleapplication
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+ cmake_src_prepare
+ sed -i \
+ -e "s|\(execute_process.*\)\${EPSON_INSTALL_ROOT}|\1${D}|g" \
+ -e "s|^\(set(EPSON_VERSION \).*|\1-${PV})|g" \
+ CMakeLists.txt || die
+ rm -rf thirdparty/{HaruPDF,rapidjson,zlib}
+ sed -i \
+ -e '/thirdparty\/HaruPDF/d' \
+ -e '/thirdparty\/zlib/d' \
+ -e 's|^\([[:blank:]]*\)\(usb-1.0\)|\1\2\n\1hpdf\n\1z|' \
+ src/Controller/CMakeLists.txt || die
+}
diff --git a/media-gfx/epsonscan2/metadata.xml b/media-gfx/epsonscan2/metadata.xml
new file mode 100644
index 0000000..c46102c
--- /dev/null
+++ b/media-gfx/epsonscan2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <longdescription lang="en">
+ Epson Scan 2 is Linux software for Epson scanners and multifunction printer.
+ Epson Scan 2 has own front-end, it allows to set various scanner settings
+ with graphical user interface and save the scanned images to the various file type.
+ It supports USB and network connection for the network capable scanners.
+ Scanner can be controlled via not only own front-end but also command line option.
+ </longdescription>
+</pkgmetadata>