summaryrefslogtreecommitdiff
path: root/games-board/polyglot/polyglot-1.4.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <gringo@slonko.net>2014-10-20 19:29:23 +0200
committerMarcin Deranek <gringo@slonko.net>2014-10-20 19:29:23 +0200
commit8cda91f592eae07fe971e01df866f23d217ad198 (patch)
treed28fdcf2b40054287aed267568581e6486c972cf /games-board/polyglot/polyglot-1.4.ebuild
parente7900f5e6e44bc6a2cf6c4f25fa27f739d24c9d3 (diff)
downloadportage-8cda91f592eae07fe971e01df866f23d217ad198.tar.gz
portage-8cda91f592eae07fe971e01df866f23d217ad198.tar.bz2
portage-8cda91f592eae07fe971e01df866f23d217ad198.zip
Added stockfish chess engine
Diffstat (limited to 'games-board/polyglot/polyglot-1.4.ebuild')
-rw-r--r--games-board/polyglot/polyglot-1.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-board/polyglot/polyglot-1.4.ebuild b/games-board/polyglot/polyglot-1.4.ebuild
new file mode 100644
index 0000000..d796e70
--- /dev/null
+++ b/games-board/polyglot/polyglot-1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit games
+
+MY_P="${PN}_${PV/./}"
+
+DESCRIPTION="UCI adapter to connect a UCI chess engine to an xboard interface"
+HOMEPAGE="http://wbec-ridderkerk.nl/html/details1/PolyGlot.html"
+SRC_URI="http://wbec-ridderkerk.nl/html/downloada/fruit/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect {CXX,LD}FLAGS, don't strip
+ sed -i \
+ -e "s:\(CXX\|LD\)FLAGS \+=:\1FLAGS +=:" \
+ -e "/LDFLAGS.*-s/d" \
+ src/Makefile || die "sed in Makefile failed"
+}
+
+src_compile() {
+ cd src
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/${PN} || die "dobin failed"
+ dodoc readme.txt || die "dodoc failed"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r "${WORKDIR}"/example/* || die "doins failed"
+ fi
+}