summaryrefslogtreecommitdiff
path: root/games-action/minecraft/minecraft-1.6.93-r1.ebuild
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2020-05-13 12:57:48 +0200
committerMarcin Deranek <marcin.deranek@booking.com>2020-05-13 12:57:48 +0200
commitdf5cf4d88d3e5a766e972f1bf3a508349261600c (patch)
treee91458b3debd773f1f5d7c5601c5f5b4a2edb643 /games-action/minecraft/minecraft-1.6.93-r1.ebuild
parent71fca106ff9d305ff669e11f89057c4c5f4ebe89 (diff)
downloadportage-df5cf4d88d3e5a766e972f1bf3a508349261600c.tar.gz
portage-df5cf4d88d3e5a766e972f1bf3a508349261600c.tar.bz2
portage-df5cf4d88d3e5a766e972f1bf3a508349261600c.zip
Updated version
Diffstat (limited to 'games-action/minecraft/minecraft-1.6.93-r1.ebuild')
-rw-r--r--games-action/minecraft/minecraft-1.6.93-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-action/minecraft/minecraft-1.6.93-r1.ebuild b/games-action/minecraft/minecraft-1.6.93-r1.ebuild
new file mode 100644
index 0000000..137b1f2
--- /dev/null
+++ b/games-action/minecraft/minecraft-1.6.93-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop
+
+MY_JAR="${PN}-launcher-${PV}.jar"
+
+DESCRIPTION="Official Java launcher for Minecraft"
+HOMEPAGE="https://minecraft.net"
+SRC_URI="https://launcher.mojang.com/v1/objects/eabbff5ff8e21250e33670924a0c5e38f47c840b/launcher.jar -> ${MY_JAR}
+ https://minecraft.net/android-icon-192x192.png -> ${PN}.png"
+
+LICENSE="Minecraft-clickwrap-EULA"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ media-libs/openal
+ virtual/opengl
+ >=virtual/jre-1.8"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/games/"${PN}"
+ newins "${DISTDIR}/${MY_JAR}" launcher.jar
+
+ dobin "${FILESDIR}"/minecraft
+
+ doicon -s 192 "${DISTDIR}/${PN}.png"
+ make_desktop_entry "${PN}" "${PN^}" "${PN}"
+}
+
+pkg_postinst() {
+ einfo "This package has installed the Java Minecraft launcher."
+ einfo "To actually play the game, you need to purchase an account at:"
+ einfo " ${HOMEPAGE}"
+}