summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-01-08 20:31:57 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2023-01-08 20:57:05 +0100
commitcc55dc467d02174abffd229039b9ca744e2a87dc (patch)
treec7ad24c06f78b7de5500b10dfe854afb35f02e4a /dev-python
parent63083430bc6f4fc47fd241febb566b0121bbf422 (diff)
downloadportage-cc55dc467d02174abffd229039b9ca744e2a87dc.tar.gz
portage-cc55dc467d02174abffd229039b9ca744e2a87dc.tar.bz2
portage-cc55dc467d02174abffd229039b9ca744e2a87dc.zip
Improvements/fixes to dev-python/daphne ebuilds
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/daphne/Manifest4
-rw-r--r--dev-python/daphne/daphne-3.0.2.ebuild39
-rw-r--r--dev-python/daphne/daphne-4.0.0.ebuild6
3 files changed, 46 insertions, 3 deletions
diff --git a/dev-python/daphne/Manifest b/dev-python/daphne/Manifest
index f9828c0..c6ee076 100644
--- a/dev-python/daphne/Manifest
+++ b/dev-python/daphne/Manifest
@@ -1,3 +1,5 @@
+DIST daphne-3.0.2.gh.tar.gz 38533 BLAKE2B b2c8dfd6fd575925262d1d6ecda46e34e45150a94e196b92a3d0014beacc6b9ab7798f448d09e04cb735dcc0cb81d7538d186a7d545ac68fd39533ce1604c7c2 SHA512 b96ef908ee9717ffa09952b2dec287cf32f59d828bda4f69b5fbae7cd815212b685e62d3f2cb8542d9b5a18d17070ca2b454bf6cdf6a55450002ff14d4b91abd
DIST daphne-4.0.0.gh.tar.gz 42313 BLAKE2B 3ab65d0d6bb01910bb83e3cf1a32172cd884b7160ed95cf9915db6b256f6291d57ba0c7c2f9c00ecb0ff8e258eb624ab16b553c6832f1082c8352ee108080d6b SHA512 a07bb10e70ded1d85146224d33049f790cb01693bd515086d9a0fc4072c308ba9f744ff1a7031d4a84eb7a763a13921a44c38a6af752ae68f44162351e8851f2
-EBUILD daphne-4.0.0.ebuild 806 BLAKE2B 54fbd6e5ffbdd9e185bd1330df6c13f09eb1f3955d57a60d42b5c613ddf3ff4b6d497e81b82225a5944226425896493643299feaf8ae23f6efe0cab21d247978 SHA512 810f42b76e0acba5cc5edf52a50a056820c9128974f1483338f49d07f8cb16589e313fb95155c2b0288d2c08ef21311287d29cc62a4416e058b670ea97cb7294
+EBUILD daphne-3.0.2.ebuild 871 BLAKE2B b1d53862ca9493211b998c1c77dfeaa8cd0522d380e81f43cb079047bf28426e9fc1da56d6c08264a7ad8de8a250a3407e74692bd925fbc01c35c36c77fa6200 SHA512 194e93ba792786ae22e8a0522d31b1c02081daaa03f054367d817940a3ca7e8294f7cc0c6851cc1504face4b53fdb0f059a949af623f34d752f91ba7115c85d2
+EBUILD daphne-4.0.0.ebuild 915 BLAKE2B 7e946a17f1b5eadd487939145509e303e4d828bd2ac0860095f8c3e0216700031c1f697f1d883e0da350338db93e3fed8c8196f5a73e11f91d6d23265604f5d1 SHA512 8e5a0fa9c019e5670c281b6f71274f90e477dcd4ee999c93ac89a9c978dd89ac9ff14f03252c367f23c581b4d6e97b646df8e5448e013a2e8b41395c43e338f1
MISC metadata.xml 438 BLAKE2B b5248aca993d71cd66e8df0d827ce104eaed0ab1bb6085f93c5cc0aebdd055fc2d4d61ebdb0ab14e60bd0f6b4e3896e74b863e7225e2208e2f600dab256d09b6 SHA512 9e2efec72be82988a08692f669d1f9fa0a6c80efbed384276e44d314ff47327ad99082cdcb492e2e83d23f72712ac12479abcd44772134a96addc8a4b5ab56ea
diff --git a/dev-python/daphne/daphne-3.0.2.ebuild b/dev-python/daphne/daphne-3.0.2.ebuild
new file mode 100644
index 0000000..e188ae1
--- /dev/null
+++ b/dev-python/daphne/daphne-3.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP, HTTP2 and WebSocket protocol server for ASGI and ASGI-HTTP"
+HOMEPAGE="https://github.com/django/daphne"
+SRC_URI="https://github.com/django/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-python/asgiref-3.2.10[${PYTHON_USEDEP}]
+ <dev-python/asgiref-4.0[${PYTHON_USEDEP}]
+ >=dev-python/autobahn-0.18[${PYTHON_USEDEP}]
+ >=dev-python/twisted-18.7[ssl,${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+DOCS=( README.rst )
+
+distutils_enable_tests pytest
+
+src_test() {
+ ASGI_THREADS=4 distutils-r1_src_test
+}
diff --git a/dev-python/daphne/daphne-4.0.0.ebuild b/dev-python/daphne/daphne-4.0.0.ebuild
index cf91783..6c3802e 100644
--- a/dev-python/daphne/daphne-4.0.0.ebuild
+++ b/dev-python/daphne/daphne-4.0.0.ebuild
@@ -18,9 +18,11 @@ KEYWORDS="~amd64"
IUSE=""
DEPEND="
- dev-python/autobahn[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.5.2[${PYTHON_USEDEP}]
+ <dev-python/asgiref-4.0[${PYTHON_USEDEP}]
+ >=dev-python/autobahn-22.4.2[${PYTHON_USEDEP}]
>=dev-python/django-3.2[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
+ >=dev-python/twisted-22.4[ssl,${PYTHON_USEDEP}]
"
BDEPEND="
test? (