summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorMarcin Deranek <marcin.deranek@booking.com>2023-01-03 23:27:46 +0100
committerMarcin Deranek <marcin.deranek@booking.com>2023-01-03 23:27:46 +0100
commitbd7db493564018ba4fc50e0cd843543517dc15d6 (patch)
treef3d1901a899bcff738317f154778d52879d70cc5 /dev-python
parent74633d69f92eb2124b1cf4c7cf284f9ed723f275 (diff)
downloadportage-bd7db493564018ba4fc50e0cd843543517dc15d6.tar.gz
portage-bd7db493564018ba4fc50e0cd843543517dc15d6.tar.bz2
portage-bd7db493564018ba4fc50e0cd843543517dc15d6.zip
Initial ebuild for dev-python/whitenoise
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/whitenoise/Manifest3
-rw-r--r--dev-python/whitenoise/metadata.xml13
-rw-r--r--dev-python/whitenoise/whitenoise-6.3.0.ebuild32
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/whitenoise/Manifest b/dev-python/whitenoise/Manifest
new file mode 100644
index 0000000..30ceff9
--- /dev/null
+++ b/dev-python/whitenoise/Manifest
@@ -0,0 +1,3 @@
+DIST whitenoise-6.3.0.gh.tar.gz 55600 BLAKE2B 354d382c20412799a4739585ea3b74ba81e3361f6145140893e145ab93471c3695e53a4e1927651106c5c32f048e52aab6c6958e4200519412b2391468d19ffe SHA512 c293e003167cb7c7aa63564bc373719f066f5e1b5cceaf0c9ceb19bd95284c321d557b988599f848d097b6c3bec3e692f7d026a835060b2fea803abf38ff924f
+EBUILD whitenoise-6.3.0.ebuild 689 BLAKE2B 1653950c6af65bd479501c60930b6922654b054efb48641bee6493f41f6d0cca6309d8d40fcbfb13f6f5bfd7ddd123dcda0e8e388ce6111ed2e0e7ea95e3e019 SHA512 beb422aab5d7ae72b99dddc0d863a92de9372fb6bfe5a7c7e61da7ad5376677934a0ee50c25fe3a9379978d762d2bd68eea58b25428bec2c5df5b47b3c0d6c79
+MISC metadata.xml 450 BLAKE2B 793f5534a52972b0eedf38a01a0fe148b26f4b3434a983184a3d3f7ae6c9edb330100fabc7abf2ac38f04b5ac1b976f9aa02e0c4bcf4fedd3b09550a1e86f4d4 SHA512 772ce944e42b9fe73bfbc6826a6feff6a94030802a9cf122e264d5ec3df306447b9aec6ab5a9f1e70bf3e13a482d20f385745d218b08deff7085bad4e001b94d
diff --git a/dev-python/whitenoise/metadata.xml b/dev-python/whitenoise/metadata.xml
new file mode 100644
index 0000000..f01837a
--- /dev/null
+++ b/dev-python/whitenoise/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marcin.deranek@slonko.net</email>
+ <name>Marcin Deranek</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/evansd/whitenoise/issues</bugs-to>
+ <remote-id type="github">evansd/whitenoise</remote-id>
+ <remote-id type="pypi">whitenoise</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/whitenoise/whitenoise-6.3.0.ebuild b/dev-python/whitenoise/whitenoise-6.3.0.ebuild
new file mode 100644
index 0000000..829d09b
--- /dev/null
+++ b/dev-python/whitenoise/whitenoise-6.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Portalocker is a library to provide an easy API to file locking."
+HOMEPAGE="https://github.com/evansd/whitenoise"
+SRC_URI="https://github.com/evansd/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+DEPEND="
+ dev-python/django[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ app-arch/brotli[python,${PYTHON_USEDEP}]
+ )
+"
+
+pkg_postinst() {
+ optfeature "brotli compression" "app-arch/brotli[python]"
+}